No announcement yet.

Help with fixing attachments (paid, if needed)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with fixing attachments (paid, if needed)

    Hello guys,

    I am looking for experienced dev, who could help me to fix corrupted attachments and documents after moving to another server.

    Hello guys, this weekend we moved our application to another server (Apache). Everything seems to be working properly, except for some email attachments. Some of the attachments cannot be displayed and instead, we are getting a little icon of the image. I double-checked that the attachment with the related ID was

  • #2
    Hello Jakub Grufik
    i'm sorry to hear that you have issues with migration.

    The best approach is to create a backup with proper script. Here you have an example:

    After you pack everything, you'll have to move package to new server, extract everything, import database and then it should work.
    Now you can try again with migration only attachments. You can also check id of missing attachments, log in to ftp and check whether this file is available on server.
    You can check permissions to attachments.

    If you still have issues, you can contact us and we'll fix this for you.

    Take care!


    • Jakub Grufik
      Jakub Grufik commented
      Editing a comment
      hello man, thank you for the tips.

      The problem is than when I take some attachment from the original respository and add there .pdf then it is working perfectly fine.

      When I copy this file to the new repository to folder Upload, it is immediately corrupted and in thy system, it is being displayed incorrectly. So the problem should not be that some of the files are corrupted during the transfer. I have absolutely no idea what could be causing this. Because some of the attachments are not corrupted and some of them are. (like 50/50). All new attachments and documents are working perfectly fine.

      The only problem is with already existing documents and attachments. As I mentioned I found the corrupted documents by ID in the original CRM where it is working without any problem, manually transferred them to the new server and they are being displayed incorrectly immediately.

      I am going to recheck with our hosting provider if there are all the required php extensions installed on the server. But if this wont be causing the issue I have no clue what could be. Is not there any script that handles already existing documents that could possibly be transfered incorrectly to the new server or something like that? I think it is not connected with broken files in the upload drectory. Because as I said, I tried to put there not broken files manually from the original CRM and they are still being corrupted.

  • #3
    That's weird. Are you able to confirm whether this issue is related to ALL attachments migrated from previous server? Or there is a problem only with PART of attachments?


    • Jakub Grufik
      Jakub Grufik commented
      Editing a comment
      now when I am going through it it seems like 90% of the old documents (mostly PDFs) are broken. Could it be that some script that handles encoding or decoding or something like that was not transferred successfully? I am really hopeless at the moment because reuploading Upload folder will not resolve the issue because all the files are corrupted immediately when transferred to FTP even when I do not try to render them via APP, I just put completely correct attachment to the FTP, then immediately download it back from FTP and its already broken within 5 sec.

  • #4
    Click image for larger version

Name:	image.png
Views:	227
Size:	215.9 KB
ID:	91183Corrupted PDF​


    • #5

      delete cache foler.
      disable cache .. try ?

      if resolve, you have a corrupted file... certainly in custom folder.. you need check one by one.


      • Jakub Grufik
        Jakub Grufik commented
        Editing a comment
        Hello man, I am going to try to delete cache folder and turn off the cache in the system. Thanks for the tips

    • #6
      item disabling cache in the system and then deleting the cache folder (which was empty anyway) did not help. I tried to turn it off, delete folder and then reuploaded correct attachment to the Upload folder, and the PDF is still immediately broken.
      Attached Files


      • #7
        Here on the video you can see that I have completely working file from Upload.
        1. Added .pdf displayed without any problem.
        2. Uploaded it to Upload of broken CRM.
        3. Downloaded back immediately without opening CRM
        4. Added .pdf to try to check it
        5. its broken already..

        I just dont get it

        This is "New Recording - 19. 4. 2023 10:10:57" by Jakub Grufík on Vimeo, the home for high quality videos and the people who love them.


        • #8
          Did you use transmission type "binary mode"? Maybe Filezilla with drag and drop does something wrong.