No announcement yet.

Unable to load user profile, preferences, system settings; "Loading"

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to load user profile, preferences, system settings; "Loading"

    I am trying to evaluate Espo to see if it will do what I need for my company and I have been stuck just trying to get the initial setup working properly.

    I installed it on my shared hosting account at A Small Orange, all the tests were fine during install, I added the base URL for .htaccess modrewrite to point to the proper directory (if I change it I get an error so I assume its working), and I have checked permissions (even tried to set everything to 755 before deleting and reinstalling).

    Nothing I do seems to fix the problem. If I click the menu on the right and select my user (Admin) I get the yellow rectangle that says "Loading" at the top but nothing happens. Same thing happens if I click Preferences. If I click Administration I get that page no problem, but if I click Settings (system settings) or Authentication nothing happens except the "Loading" box.

    Obviously I'm not going to proceed if I can't get this working and it seems like Espo will end up working for what I want if I can get these issues resolved.

    Any help is appreciated!

  • #2
    I revisited my installation just now to see what I could play with and it seems almost nothing works. I just get "Loading".... I try to create a new task, a new call, etc and I just get "Loading".


    • #3
      try using Softaculous app-installer at your host. that version of espo have you installed?


      • #4
        The version I installed was the one downloaded from this site (4.1.2) and the one my host has in softaculous is 4.1.1. I removed the one I installed and used softaculous and it does exactly the same things.


        • #5
          Interestingly enough, the "Working" banner on top of this forum post stays there and no post appears until I refresh the page. I tried using the espo crm on a windows computer at work and it does the same thing.


          • #6
            Can you check server's error log?


            • #7
              We've have version 5.0.3 installed, love what we see, but running into the same issue as this original post: "Unable to load user profile, preferences, system settings; "Loading".
              We've confirmed server settings, etc, could use some guidance. Thanks.


              • #8

                Could you check your server's error log for errors. Also espocrm log at data/logs directory.


                • #9
                  Hello! Same problem here...
                  Installed version 5.25 from Softaculous, in a subdomain within my hosting services (Installed over https.// protocol)
                  Installation correct. Settings ok,
                  requirements: met

                  Loading ok,
                  Logging in: ok

                  Errors: Creating Accounts, creating contacts, creating leads, creating Opportunities, accessing Settings (most of them)

                  When logging I briefly glanced an auth error displayed for a second. So my guess is there is an issue with accessing it through SSL

                  A portion of SSL Error Log:

                  [08/Jun/2018:14:33:13 -0400] "GET /client/src/views/scheduled-job/fields/scheduling.js?r=1528480768 HTTP/1.1" 200 1567 "" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0"
                  [08/Jun/2018:14:33:14 -0400] "GET /api/v1/Notification/action/notReadCount HTTP/1.1" 200 1 "" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0"
                  [08/Jun/2018:14:33:17 -0400] "GET /api/v1/Activities/action/popupNotifications HTTP/1.1" 200 2 "" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0"
                  [08/Jun/2018:14:08:12 -0400] "GET /api/v1/Notification/action/notReadCount HTTP/1.1" 200 1 "" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134"


                  • #10
                    Hi there,
                    I have the same problem just for showing contacts/creating contacts

                    No error.log entry about a problem on web and apache logs just the same as ideawmx wrote.

                    Is there now a solution for this?

                    All the best


                    • #11
                      What error did you get? Bad server response?
                      If problem is only in contacts, any record has to be added in espo log ({espodir}/data/logs/)
                      if you have no files - check permission