No announcement yet.

Error 500 when opening EspoCRM

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 500 when opening EspoCRM

    When opening Espo today I encountered an error 500.

    I checked the forum and did not see anything that fit my situation.

    My installation:
    * Espo is installed using bitnami and is installed on Oracle VirualBox and my Windows 10 PC.

    To open Espo using this set up I have to do the following:
    1) Open VirtualBox
    2) Double click on EspoCRM icon. (This starts the Debian 11 Virtual Machine where Espo is installed)
    3) Open browser and navigate to the IP address for Espo

    Everything goes well until I navigate to the IP address for Espo. This is when I get the Error 500 notification.

    Any ideas as to why I am getting this error and how to fix it?

    Thank you to everyone in advance for any all help you can provide.


  • #2
    Please provie error log from data->logs


    • #3
      Thanks shalmaxb for responding. Would you be able to tell me how to navigate to data->logs?


      • #4
        It is in your installation folder, in your webfolder data->logs, the most recent file there


        • #5
          I have a similar problem. But nothing is written in data->logs. Everything is included in the admin panel. But logs are not written!


          • #6
            Thanks shalmaxb! I will look to see if there is anything data->logs. Sorry for the delay in getting back to you.


            • #7
              I finally freed up some time and figured out how to navigate to the data->logs.

              The log file says that I have a "Slim Application Error Type: RuntimeException Code: 0 Message: Invalid"

              I have included an image of the log contents.

              Any idea on how to fix this?

              Please keep in mind that I am new to all this.

              Any and all help will be appreciated in fixing this error.


              • #8
                Ok, that is not much to aim to the real error. There are two more places to look:

                1. Server logs
                2. Open your browser and hit F12 (Browser Tools), then try to connect again with your installation. In the browesr tools open the Tab "Console". There should be error messages. Perhaps you will get closer to the error.


                • #9
                  I opened up Espo using the Browser Tools and there are some errors. I have included an image of the contents.

                  I do not know how to get the the server logs. So let me know where they would be if you think I need to look there.

                  Thanks again for your help!


                  • #10
                    I don`t know, where in that bitnami stack/virtual machine it is located. Search in the stack for the Apache installation, which is the server. In the Apache folder (normally it is named "apache2"), there is another folder "logs", where the log file is present.
                    The screenshot from the console has the errors closed, click on the little triangle in front of the error to open the complete message. Maybe it will be more informative.

                    The other day you uploaded an image of the espoCRM error log. I suspect, that there might be more information. Could you download the whole espo log file and attach here?


                    • #11
                      I have seen an apache folder in the bitnami stack. I will try and find the log files.

                      I have included the images from the expanded console errors.

                      What would the whole Espo log file look like? When I am in the log file I see 8 to 10 dated log files. Do you want images of the contents of those files or something else?

                      Thanks again!​
                      Last edited by Cuz; 12-03-2023, 05:10 AM.


                      • #12
                        what is your PHP Version?


                        • #13
                          Where would I find the PHP version?

                          I was able to navigate to the apache2 file and read one of the logs. I hope it makes sense to you. It doesn't make sense to me.

                          Did the Console Errors tell you anything?


                          • #14
                            As you can see in the info line (top line with white background) you are looking into a zipped file (gz extension). You must unpack that file to be able to read it.

                            To get the php version, you must upload a file into your root directory and call that file in the browser. Please search in search machine for that.

                            Already now and on the long run you will have to learn a bit more about server and server software, database and all that stuff. To use espoCRM you must not be a developer, but certainly need to know more than writing an email.
                            There is also a thorough documentation for espoCRM. Reading that, often also helps. And learning by doing makes part of it also.


                            • #15
                              I was wondering why the file was unreadable. I tried to install unzip but Linux could not find it. (Please see image)

                              Regarding the PHP version. I followed bitnami's procedure to get the PHP information and received a 404 Error when I opened the browser. Which probably means that I did something wrong. Tried it again today with no luck. (Image below of the phptest.php file)

                              I did see that VirtualBox has some logs for Espo and I did see that it had something saying "(Bus/Target) doesn't exist". I don't know if this means anything regarding the problem I am having. I tried to check the VirtualBox forum to get more info but their site is down. (SQL ERROR [ mysqli ] The server is currently in offline mode​).

                              I know I have a lot to learn and I will look into the resources you suggested.

                              Thanks again for all of you help