No announcement yet.

SMTP Errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP Errors

    I'm getting the attached SMTP error when sending reports or other e-mails from a personal e-mail account, although the test e-mail was sent just fine during setup of the same personal e-mail account.

    Here's the error log:
    HTML Code:
    [2018-07-31 06:09:58] Espo.ERROR: API [POST]:/:controller, Params:Array (     [controller] => Email ) , InputData: {"isHtml":true,"body": .. [] []
    [2018-07-31 06:09:58] Espo.ERROR: Display Error: 5.7.8 Error: authentication failed: UGFzc3dvcmQ6 , Code: 500 URL: /api/v1/Email [] []
    What's wrong?

  • #2
    What EspoCRM version?


    • #3
      EspoCRM 4.8.4 w/ Advanced Pack 1.27.0 (I guess, couldn't find the version in the backend though)


      • #4
        Those are pretty old versions. I recomend upgrading to the latest EspoCRM version and advanced pack.

        You can find the current version on About page.


        • #5
          Will do and circle back to you should the error persist.


          • #6
            Hi again, tried to upgrade from 4.8.4 to 5.0.5 yet getting "Error: Null" - find some screenshots attached.

            The /runUpgrade request results in Status Code 500 Internal Server Error - compare screenshot attached (I've removed the sensitive parts from the screenshot...).

            The data/logs do not contain any (related) logs at all.

            Please note that all tables are InnoDB, in case this makes any difference to the installation process.

            Any ideas?


            • #7
              Check server log.


              • #8
                The upgrade issue could be solved by increasing wait_time for MySQL to a higher value.

                Current version is 5.3.5, but we still cannot send e-mails - other than the test e-mails - for our personal e-mail accounts:

                Error 500: 5.7.8 Error: authentication failed: UGFzc3dvcmQ6

                Attached, please find the settings for the personal e-mail account.

                Please advise.


                • #9
                  Make sure you don't have wrong SMTP credentials set in user preferences. I recommend erasing SMTP settings in preferences.


                  • #10
                    How could the credentials be wrong when the test email is being sent correctly?


                    • #11
                      Here's a screenshot of the SMTP settings.


                      • #12
                        Sorry, but I need to push this topic again, since we really need to be able to send e-mails using our personal accounts.

                        Any suggestions what to do?


                        • #13
                          Have you checked user's Preferences as I advised above? You didn't report.
                          Last edited by yuri; 08-06-2018, 12:56 PM.


                          • #14
                            Of course I've checked (and removed and added again the SMTP settings), Also, I've reported back (post #10) and also sent a screenshot (post #11).


                            • #15
                              That screenshot of Email Account detail view, I meant Preferences. Find user's Preferences > SMTP.

                              Post #10 was a question.
                              Last edited by yuri; 08-06-2018, 01:10 PM.