Announcement

Collapse
No announcement yet.

Search not being executed as you start typing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by yurikuzn View Post
    I'm not sute if it was ever designed to use 'contains' in an autocomplete lookup. I will look into.
    Maybe that's the "problem". If you use %, it works on autocomplete. It would be great to have the contains on the same way.

    By the way, the "*" is not working as well (for autocomplete)

    Comment


    • #17
      There reason:

      There is a limitation (config parameter textFilterContainsMinLength). When you type a first few characters it doesn't return any result due to parameter. Then you type more characters than set in 'textFilterContainsMinLength' but the autocomplete library that we use doesn't lookup since the previous results were empty. I will look into how we can overcome this behaviour.

      You can try to set 'textFilterContainsMinLength' => 1 in config. It may work out.

      Comment


      • #18
        Originally posted by rodrigocoelho View Post

        Maybe that's the "problem". If you use %, it works on autocomplete. It would be great to have the contains on the same way.

        By the way, the "*" is not working as well (for autocomplete)
        Perfect. Working now. MUCH BETTER. Thanks Yuri.

        Comment


        • #19
          Originally posted by yurikuzn View Post
          There reason:

          There is a limitation (config parameter textFilterContainsMinLength). When you type a first few characters it doesn't return any result due to parameter. Then you type more characters than set in 'textFilterContainsMinLength' but the autocomplete library that we use doesn't lookup since the previous results were empty. I will look into how we can overcome this behaviour.

          You can try to set 'textFilterContainsMinLength' => 1 in config. It may work out.
          Where are these GEMS explanations? What more special settings for using on config we don't know?

          Comment


          • #20
            tanya mentioned this on other post. Take a look. https://forum.espocrm.com/forum/gene...the-name-field

            Maybe the default could be 1.

            Comment

            Working...
            X