Announcement

Collapse
No announcement yet.

Search not being executed as you start typing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search not being executed as you start typing

    When start typing on a search field, it works better when having % on the search field. Even having the option "Use 'contains' operator when filtering varchar fields" activated, some fields don't work as contain if not using % manually.

    Some Entities, after enabling Full Text Search, only works if you start with %. If not, it doesn't search as you start typing.

  • #2
    Please provide more details, maybe screenshots. l'm really confused and don't understand.

    EspoCRM doesn't have a search triggered on typing. Only autocomplete link fields have it.
    Last edited by yurikuzn; 12-15-2018, 06:15 AM.

    Comment


    • #3
      I'm sorry Yuri. Maybe because my bad english. Let's try with screen captures.

      Below, an example of me typing scania, and it showing everything but scania. Some times, it shows nothing.

      Click image for larger version

Name:	Capturar.JPG
Views:	2
Size:	59.6 KB
ID:	44216

      Now it's me typing %scania and it returns what I want.


      Click image for larger version

Name:	Capturar.JPG
Views:	1
Size:	44.8 KB
ID:	44217

      Here it shows contains enabled all time:
      Click image for larger version

Name:	Capturar.JPG
Views:	1
Size:	10.6 KB
ID:	44218


      Attached Files

      Comment


      • #4
        Hi Rodrigo,

        I this 5.4 or 5.5 version?

        Do you have full-text enabled for Projecto entity type?

        Comment


        • #5
          Originally posted by yurikuzn View Post
          Hi Rodrigo,

          I this 5.4 or 5.5 version?

          Do you have full-text enabled for Projecto entity type?
          Hi Yuri. version 5.5.3. In some places, it works like expected, in others not. Only works when using "%".

          Yes, full-text enabled.

          Comment


          • #6
            Originally posted by rodrigocoelho View Post

            Hi Yuri. version 5.5.3. In some places, it works like expected, in others not. Only works when using "%".

            Yes, full-text enabled.
            5.5.5 and still not working

            Comment


            • #7
              Originally posted by rodrigocoelho View Post

              5.5.5 and still not working
              Hi, should I post this on Bug Report of GITHUB?

              thanks

              Comment


              • #8
                Hi,

                No need.

                Do you have the same issue w/o full-text enabled?

                Comment


                • #9
                  Originally posted by yurikuzn View Post
                  Hi,

                  No need.

                  Do you have the same issue w/o full-text enabled?
                  Yes, just tried.

                  And the behavior using "*" is not like when using "%".

                  Comment


                  • #10
                    Did you run rebuild after disabling full-text?

                    Comment


                    • #11
                      Originally posted by yurikuzn View Post
                      Did you run rebuild after disabling full-text?
                      Yes....

                      Comment


                      • #12
                        Originally posted by rodrigocoelho View Post

                        Yes....
                        If you would like to try yourself, you can enter on the system to try.

                        Comment


                        • #13
                          I tried but couldn't reproduce. Searching by the word "scania" in parent field gives a proper result.

                          Comment


                          • #14
                            Seems I reproduced.

                            Comment


                            • #15
                              I'm not sute if it was ever designed to use 'contains' in an autocomplete lookup. I will look into.

                              Comment

                              Working...
                              X