Announcement

Collapse
No announcement yet.

Search not being executed as you start typing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search not being executed as you start typing

    When start typing on a search field, it works better when having % on the search field. Even having the option "Use 'contains' operator when filtering varchar fields" activated, some fields don't work as contain if not using % manually.

    Some Entities, after enabling Full Text Search, only works if you start with %. If not, it doesn't search as you start typing.

  • #2
    Please provide more details, maybe screenshots. l'm really confused and don't understand.

    EspoCRM doesn't have a search triggered on typing. Only autocomplete link fields have it.
    Last edited by yurikuzn; 12-15-2018, 07:15 AM.

    Comment


    • #3
      I'm sorry Yuri. Maybe because my bad english. Let's try with screen captures.

      Below, an example of me typing scania, and it showing everything but scania. Some times, it shows nothing.

      Click image for larger version

Name:	Capturar.JPG
Views:	2
Size:	59.6 KB
ID:	44216

      Now it's me typing %scania and it returns what I want.


      Click image for larger version

Name:	Capturar.JPG
Views:	1
Size:	44.8 KB
ID:	44217

      Here it shows contains enabled all time:
      Click image for larger version

Name:	Capturar.JPG
Views:	1
Size:	10.6 KB
ID:	44218


      Attached Files

      Comment


      • #4
        Hi Rodrigo,

        I this 5.4 or 5.5 version?

        Do you have full-text enabled for Projecto entity type?

        Comment


        • #5
          Originally posted by yurikuzn View Post
          Hi Rodrigo,

          I this 5.4 or 5.5 version?

          Do you have full-text enabled for Projecto entity type?
          Hi Yuri. version 5.5.3. In some places, it works like expected, in others not. Only works when using "%".

          Yes, full-text enabled.

          Comment

          Working...
          X