Announcement

Collapse
No announcement yet.

Upgrade from 7.2.7 to 7.3.2 does not work with PHP > 8.0.x

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade from 7.2.7 to 7.3.2 does not work with PHP > 8.0.x

    Hi yuri

    I tested the instance upgrade from 7.2.7 to 7.3.2 with PHP set to 8.1.12. When i run the upgrade, it runs up to "downloading..." and then it just terminates without upgrading. I repeated the same upgrade with PHP 8.0.25 and it works fine.

    Is there something i need to do for PHP > 8.0.x?

  • #2
    murugappan,

    I don't know if my experience will be useful for you, but today I upgraded from EspoCRM 7.2.7 to 7.3.2 on PHP 8.1.2. Everything went without any errors, although before upgrading I did sudo apt upgrade on my Ubuntu...

    Comment


    • murugappan
      murugappan commented
      Editing a comment
      victor, I am using CPanel on a vps hosting serve with Centos Server. Also i run the script using root therefore i dont need to sudo.
      Last edited by murugappan; Yesterday, 10:28 AM.

  • #3
    Hi,

    On testing further, I getting the following error in the error.log:

    Allowed memory size of 33554432 bytes exhausted (tried to allocate 14976300 bytes) in /home/sysdev/public_html/wellnessclinicx/application/Espo/Core/Console/Commands/Upgrade.php on line 294
    I have set the memory_limit to -1 and also 1024M. Nothing seems to work. Its odd when i do the same upgrade with PHP 8.0.7 it seems to work fine.

    Any help, please?

    Comment


    • #4
      I encountered the same error when running the below command in my EspoCRM directory
      Code:
      php command.php upgrade
      Even though I have that directory set to PHP 8.0, I needed to use the exact path of PHP 8.0.
      Code:
      /usr/local/php80/bin/php command.php upgrade
      Once I used the exact path to PHP 8.0, everything worked fine. I also needed to update my cron jobs as well. Have not had any issues since.

      Comment


      • murugappan
        murugappan commented
        Editing a comment
        Hi,

        I am using CPanel. Therefore i dont have to set the path for my php. Its already set. Moreover, i do not have any issue with PHP 8,0.7. The problem i am having now is for PHP 8.1.x
    Working...
    X