No announcement yet.

Print to PDF Option Gone after Upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

  • Print to PDF Option Gone after Upgrade

    After upgrading Espo from 7.1.9 to 7.3.2, the print-to-pdf feature has disappeared. Server is running Ubuntu 20.04, and was running php 7.4 at the time of the upgrade. Have now upgraded to php 8.2.1. Still no print-to-pdf option anywhere.

    Can't find anything helpful in the error logs, as I cannot even try to create a pdf as the option is now gone from the dropdown menu by the edit button.

    Any ideas would be appreciated.
    Last edited by showard; 01-25-2023, 12:31 AM.

  • #2
    Can you try creating a new template, refresh the page and try again? Does it affect all of your entity, try another entity?

    See if there any error log, which I don't think it will log this.


    • #3
      It appears to affect all entities.
      Created new templates, cleared cache, rebuilt, reloaded page, restarted espo and server....
      Still no print to pdf.
      I did find the following error message in the logs:
      ERROR: AppParam templateEntityTypeList: [] []

      ​Update: Still no "print to pdf" option on the record display dropdown menu, but BPMN processes will correctly generate pdf documents when a flowchart process is triggered.
      So the pdf engine is working, but it can only be triggered via a BPMN process.

      I suspect that the "ERROR: AppParam templateEntityTypeList: [] []" may be the key to understanding what's going on.
      Last edited by showard; 01-25-2023, 09:46 PM. Reason: Updated


      • #4

        Just tested on PHP 8.2.1, EspoCRM 7.3.1 and PHP 8.1.2, EspoCRM 7.3.2​. Couldn't reproduce the problem in both cases.
        Attached Files


        • #5
          I'm sure it's a local problem within my installation, rather than a bug. My best clue seems to be the log entry:

          ERROR: AppParam templateEntityTypeList: [] []

          My understanding is that this error indicates that the list of entities with pdf templates is an empty list.


          • #6
            Make a backup, then can you try just exacting all the file of .zip of your current version overwriting all your current file. Give that a try, then hope for the best. If it fail or blank screen or anything, revert back to the backup and try something else.

            Worse case, you might need to do a new installation and just move old system to new install version.