No announcement yet.

Error After Update to Latest Version

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error After Update to Latest Version

    Hello Developer,

    i Just updated my espo crm from 6.1.10 to 7.9 from terminal after the update complete
    i got one message. I am currently using cyberpanel to manage my server . Please Help me to configure the cyberpanel server for Espo crm

    You need to configure your webserver in order to being able to run EspoCRM. After that refresh the page.
    For Apache webserver

    You need to have mod_rewrite enabled. You can do it by running in the terminal:

    sudo a2enmod rewrite sudo service apache2 restart Non-production environment

    You need to enable `.htaccess` usage in the apache configuration. Add the code:

    <Directory /home/> AllowOverride All </Directory> Production environment

    It's recommended to configure the document root to look at the `public` directory and create an alias for the `client` directory. The code to add to the apache configuration:

    DocumentRoot /home/ Alias /client/ /home/
    And allow override for the `public` directory:

    <Directory /home/> AllowOverride All </Directory>
    See more details in the documentation.
    For Nginx webserver

    You need to configure the document root to look at the `public` directory and create an alias for the `client` directory.

    See more details in the documentation.

  • #2
    Hello yubrajkafle,

    What webserver do you use? Apache or Nginx?


    • #3
      Same problem upgrading on windows 10 with ISS !!!
      Tried to do a fresh install downloading new version.
      I think that the new version has something wrong:
      1) the index.php is totally different form the past and contain what yubrajkafle said;
      2) replacing index.php with an older index.php cannot start setup because there is no index.php file in install folder;
      3) tried to copy older index.php in install folder, setup start only first page, but cannot proceed.
      Please help


      • #4
        I solved it!!!
        After upgrade to the last version:
        1) Restore original version of index.php
        2) Restore deleted API folder
        3) Add in web.config in <staticContent>....<mimeMap fileExtension=".woff2" mimeType="application/font-woff2" />


        • #5
          This is how I solved this issue
          My Server:
          OS Ubuntu 20.04.4 LTS
          Product Plesk Obsidian
          Version 18.0.42 Update #1, last updated on Mar 21, 2022 02:20 AM

          I had this issue and got so frustrated I tried using a different CRM and was again frustrated with the change, I had MBs of info that wasn't importing in to the change. I lost a years worth of data input but I didn't give up on ESPO and this is how I fixed this issue.

          Selected the sub-domain/domain to Control Panel select the Hosting/DNS tab select Apache & NGINX enable NGINX options and you should be good to go
          I am so glad I didn't give-up completely I knew I'd get it back.
          Last edited by 440music; 04-18-2022, 09:32 PM. Reason: Solution


          • #6
            EDIT: Solved. I had not enough rights to enter additional apache directives.

            Plesk Obsidian problem hier.
            Plesk is using a combination of nginx and apache
            Migrating from another Server.

            Firefox says:
            Laden fehlgeschlagen für das <script> mit der Quelle "".​ (loading failed)

            in plesk i set Document Root to /var/www/vhosts/xxx/xxx/public/​

            But i can't set the directive Alias /client/ /var/www/vhosts/xxx/​. There is no option in plesk to do so. And cannot use .htaccess file because Alias directive is not allowed in this file.

            Will try to set a symlink
            Last edited by JayBee4pl; 01-10-2023, 12:27 PM.