Announcement

Collapse
No announcement yet.

Upgrade destroyed something

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade destroyed something

    I upgraded from 5.82 and followed the procedures to the current build. For two years prior to this upgrade, everything was running smoothly. I did appropriate backups, so I thought and even looked to the server rewinds etc. Now, every 2-4 hours the CRM crashes again and gives just the blue line across the top of the page. I literally delete everything and recreate the database and folders on the server every couple of hours which is a hit or miss issue. Sometimes it comes back up and sometimes it doesn't. This is the most maddening thing I have every experience with the software.

    Is there a way to load a new copy of the CRM and import old data?

    If not, this may be the end of the road. What a frustration!

  • #2
    It could also be a problem with the hardware.

    Comment


    • #3
      The blue line at the top only (Classic Theme) show when you do a refresh on your Web Browser or when it loading the website for the first time. It should never load at all while you using the system.

      If the server crash then (1) any record won't get load at all, hang. (2) Bad server response pop up message at middle centre of the screen. (3) blank white screen.

      If it constantly showing blue line then it abnormal.

      If you got backup, couldn't you revert back to that?

      Any issue in your logs file (enable debug too for additional logs).

      Also starting version 5.8 (from memories) there is a new server requirement (Database version and PHP version), check if your server requirement configuration is acceptable.

      Comment


      • #4
        Originally posted by Fehu View Post
        there a way to load a new copy of the CRM and import old data?
        ALWAYS make a backup before upgrade! I also use a "spare" install of espo just for testing upgrades and customizations before applying to the "work" one.

        A big (imho) weakness of espo is that there is no easy way to quickly clone every entity to another instance unless you just "copy over" with sql.
        E.g. a mass import/export procedure that creates a big zip file with the json of every entity and allow to import that in a new instance. <-- that would be awesome for interoperability
        Last edited by tothewine; 06-15-2020, 02:50 PM.

        Comment


        • #5
          F12 to check errors in browser console.

          data/logs to check error.

          Peter might be right that it's a hardware issue.

          Upgrade is mostly just replacing files with new ones. It should not cause any data loss or such odd issues. We regularly run upgrades for quite a bunch of instances and have never had any problems so that we needed to revert backups.
          Last edited by yurikuzn; 06-12-2020, 05:40 PM.

          Comment


          • #6
            Fortunately, I have backups daily so that solves the issue for about 3 hours and then back to the thin blue line. This is happening over and over again. It's maddening to say the least. I have tried virtually everything and it still errors after a few hours.

            I take new backups and have even gone back 30 days prior to the upgrade and I've noticed the config file in the data folder shows NULL for latestversion, however, the moment it crashed I look again and it shows the newest version. Not sure what files are corrupt but it's a bad nightmare.

            Comment


            • #7
              You not getting any error at all? It quite blindly from everyone unless there some information that might be able to track down the issue.

              Comment


              • #8
                config file is getting corrupted?, set with NULL?

                Here you've been asked about errors in logs a few times.
                Last edited by yurikuzn; 06-17-2020, 09:48 AM.

                Comment


                • #9
                  Yes, it's set to NULL for currentversion and then I've noticed it crashed once the actual current version is written.

                  Additionally, in Forefox and console I see the file it seems to stop loading on. It's espo.min.js

                  It hangs there and won't continue loading the crm.

                  The logs don't show any of these issues.

                  Comment


                  • #10
                    The was an issue, when the config file was being saved, a concurrent reading (by another process) of not fully saved file could cause a problem. But this problem has been there since the very first version.

                    In 5.9.0 we changed the way how the config is saved. 'rename' command is used to prevent this problem from happening.

                    There's a chance that upgrading to 5.9.0 will help.
                    Last edited by yurikuzn; 06-17-2020, 06:25 PM.

                    Comment


                    • #11
                      Yuri, the challenge is I can't upgrade because I get the blue line across the top when do. Unfortunately, the only thing I can do is retire an old copy each time I try and upgrade. I've tried many times to date with the same error each time.

                      Can you think of any other solutions that might work?

                      Comment


                      • #12
                        Might be something another. So every time you access espocrm it erases contents of config.php? Can you confirm?

                        Comment


                        • Fehu
                          Fehu commented
                          Editing a comment
                          No, it's random. I or other users can be working on it and it's fine. Unless someone tells us or we log off and try to log back in we wouldn't know it was down. Again, if we were logged on it runs as if normal but if it's "down" you only get the blue line.

                      • #13
                        Try setting maintenance mode in config:

                        'maintenanceMode' => true,

                        Disable cron:

                        'disableCron' => true,

                        Wait for a minute and then run:

                        php command.php upgrade

                        Comment


                        • #14
                          So, try this before upgrading? I'm not certain how to upgrade other than through the admin upgrade function.

                          Comment


                          • #15
                            https://docs.espocrm.com/administration/upgrading/

                            Comment

                            Working...
                            X