No announcement yet.

Changes not saving

  • Filter
  • Time
  • Show
Clear All
new posts

  • Changes not saving

    I made clean install (3 times) and the installation finishes with no errors, I can log in and can add everything. But when I change something and press save nothing happens, only Saving... displays on top.

    PUT http://<domain>/crm/api/v1/User/1 net::ERR_EMPTY_RESPONSE espo.min.js?r=1552502099:4

    Thanks for the help.

  • #2
    Check the Espo and web server error logs. This can be helpful:


    • #3
      <ESPOCRM_DIRECTORY>/data/logs/ directory not exists.

      There are only these:
      cache/ <DIR> 2019.03.14 11:28 -775
      .data 1 2019.03.14 10:55 -664
      config.php 6 514 2019.03.14 11:29 -664


      • #4
        That's ok. It means that you haven't got yet any error message. Is there some record in the web server error log?


        • #5
          The error log is empty.

          These errors were during install:
          exif Off Fail (extension is missing)
          max_execution_time 30 Fail (180 is recommended)
          max_input_time 60 Fail (180 is recommended)
          memory_limit 128M Fail (256M is recommended)
          But I think it should be working with these errors.

          I tried with php 5.6 and php 7.2 too. The same result. I can create anything, but edit nothing.


          • #6
            Try to change these configs in the php.ini file and install exif extension for php. After these changes restart your web server. Recommend you to use php 7.2. Also, check if PUT method is allowed on your server.
            Last edited by Maximus; 03-15-2019, 07:27 AM.


            • #7
              Thats very interesting, similar problem also after my installation with PHP 7.1

              My errors are:

              max_execution_time 30 failed (180 is recommended)
              max_input_time 30 failed (180 is recommended)
              memory_limit 128M failed (256M is recommended)
              post_max_size 8M failed (20M is recommended)
              upload_max_filesize 8M failed (20M is recommendedn)

              Could you (@flashmovar) solve the problem?
              I guess my hosting partner doesn't accept this changes!?