Announcement

Collapse
No announcement yet.

No data displayed in specific administration settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No data displayed in specific administration settings

    Click image for larger version

Name:	image.png
Views:	259
Size:	9.4 KB
ID:	88997
    Certain administrative settings on my EspoCRM instance are not displaying any data. The affected administration screens are:
    Settings, User Interface, Authentication, Currency, Notifications. I am also unable to make changes and save on the 'Roles' and 'Workflows' screens. The common cause seems to be related to the "middle" class used within the "record-grid" class as seen below. The divs on the affected screen within the "middle" class div are always empty. The no. of empty div rows vary between different admin screens but are always blank.

    Click image for larger version

Name:	image.png
Views:	145
Size:	55.5 KB
ID:	88998

    No errrors appear in the browser console log, apart from on the User Interface screen:
    Click image for larger version

Name:	image.png
Views:	146
Size:	28.0 KB
ID:	88999
    This issue has been apparent for several weeks. In that time I have rebuilt multiple times, ensured that Espo and extensions are up-to-date, tried creating a new instance using the same files and mysql db, all with the same result.​ I do have some 3rd party extensions installed (Layout Pro, eSignature Documents for EspoCRM, CRM Plus and Ebla Labels), and have tried removing all 3rd party extensions (apart from Advanced and Sales) on a development instance, with no difference made to the issue described. There are no errors in either the web-server or espo's log.

    I have checked the config, config-internal php files and the preferences data held on the mysql db. I have also verified the integrity of the db. I would greatly appreciate some assistance in tracking down what might be causing this issue. Thanks.

    ​​

  • #2
    I think that it could be a Layout Pro related error.
    Can you write down your EspoCRM version, PHP version, and Layout Pro version?
    Meanwhile can you go to the Settings of Layout Pro and switch the default view to Record and then rebuild?
    Click image for larger version

Name:	image.png
Views:	179
Size:	78.4 KB
ID:	89012

    Comment


    • #3
      Thank you Kharg for the explanation,

      chrisgood
      This issue is on the frontend side and not expected to see any log message on the server, will help if you list the versions of extension and the version of espo.
      CEO & Founder of Eblasoft.
      Professional EspoCRM development & extensions.

      Comment


      • #4
        Thank you for your assistance.

        PHP Version: PHP 8.2.3 (cli)
        Zend Engine v4.2.3

        EspoCRM version; 7.3.3
        Layout Pro version: 3.9.0


        Unfortunately no data is visible on the Ebla settings screen due to the issue as described with 'middle' class. Are the Ebla settings editable from mysql/json/php file?

        Attempting to save a layout in the Layout Pro layout manager results in the following error:

        Click image for larger version

Name:	image.png
Views:	134
Size:	57.0 KB
ID:	89071
        Attached Files
        Last edited by chrisgood; 03-09-2023, 09:21 AM. Reason: Additional information:

        Comment


        • #5
          Update: I uninstalled and removed the Layout Pro Plugin from a test Espo instance. After rebuilding, the LayoutPro layout manager was still functioning and the settings button was still visible on the detail view for entities. The admin screens were still not displaying data. Manually removing the plugin from both client/modules and application/modules and rebuilding appears to have fixed the issue. Out of interest I then reinstalled the plugin (version 3.9.0) and checked that the admin screens reverted to not displaying data. I then un-installed the plugin. This time the automatic uninstall worked as expected.

          eymen-elkum Kharg thank you for your assistance.

          Comment


          • #6
            If you still have issues please consider logging an issue on our portal, if you don’t have portal account yet please fill this form: https://ebla.in/contact
            I will report here the final report when the issue solved
            CEO & Founder of Eblasoft.
            Professional EspoCRM development & extensions.

            Comment

            Working...
            X