No announcement yet.

Problems with Cron Job under Windows Task Scheduler

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Cron Job under Windows Task Scheduler

    I'm still having problems with the cron job on Windows and the task scheduler. I have created a new task in the task planner. The bat file is integrated and saved. Unfortunately, the individual jobs are only ever executed once and not as specified in the individual job descriptions. What do I have to set in the Windows task planner for the trigger so that the linked Cron.bat is called once and then performs its service according to the cron job setting? What do I have to set under Administration / Job at ESPO? Can it stay that way, see picture or can I also have the jobs run in parallel or change other values?

  • #2
    Not able to decipher your screenshots, as I don't yet know German unfortunately! Are you using IIS or Windows Subsystem for Linux? If IIS, ensure your Task Scheduler service is running. If WSL, ensure you're keeping alive your WSL session, as it may be running your task once and then closing its session, which would be why consecutive tasks don't seem to execute. Also verify you're crmtask.bat is being Run As the correct user with appropriate permissions.


    • #3
      Look here, perhaps it helps:


      • #4
        Thank you, yes, that was my contribution too. But it was only about the path in the bat file. That has been clarified. Now it's about the correct settings in the Windows task planner and in the ESPO job settings.

        Originally posted by shalmaxb View Post