Announcement

Collapse
No announcement yet.

Bad server response loop - can't get back in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad server response loop - can't get back in

    Is there another way to fix this besides restore? 2nd time this has happened. I am on a shared server so I don't think I can "run" anything to stop it "BSR" displays off and on every few seconds. When I refresh the screen goes white and I have no way to log in.

    Wondering if there is some file I can delete or entry in a file?

    This time I tried to widen the menu in the Vertical-Violet file. The first time this happened I was updating layouts - happens when I "clear cache and/or rebuild"

    Error showing F12: SecurityError: Permission denied to access property "dispatchEvent" on cross-origin object
    When I click "clear cache"

    When I click Clear Cache:
    Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://ariston153.com/sdespo/client...xt-regular.ttf. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing). (unknown)

    downloadable font: download failed (font-family: "Open Sans" style:normal weight:normal stretch:normal src index:5): bad URI or cross-site access not allowed source: https://ariston153.com/sdespo/client...xt-regular.ttf

    I think I need to find the file where the theme is recorded and change that to something else.
    Please help
    Last edited by crmclients; 07-31-2020, 11:53 PM.

  • #2
    I don't know enough about themes and browser coding/management to help with a solution, but I think the error is being triggered by this script:
    https://github.com/espocrm/espocrm/b...site/navbar.js line #172.

    Hopefully this will help you search for the code that needs to be modified.

    If you need to make changes to the script, it's better to create a custom view and inherit from the system view to make the changes "upgrade safe".

    I just posted a tip on how to change the navbar view here: https://forum.espocrm.com/forum/deve...1128#post61128

    Regarding rebuilding without having to login, you can always force a rebuild from the Command Line if your hosting plan permits SSH access. I am also in a shared server and my plan permits it.

    The command is
    Code:
    php rebuild.php
    Last edited by telecastg; 08-02-2020, 12:30 AM.

    Comment


    • #3
      Ok thanks, I will look into it. I haven't modified any code except to color the bar which I realize is temporary. I switched browsers and it seems the "cross script" error is now gone but I still get the "min.js" error on Rebuild at times.

      I have not done anything to any of the files except the navbar-inverse color for the espovertical file - I was using a FFox fork and now I am using FF. F12 still shows a error (please see screen shot)

      Ill keep an eye out on it, thanks for the links!
      Attached Files

      Comment


      • #4
        Update: My host blocks SSH access and I have to get permission; meanwhile I spun up a Bitnami EspoCRM (5 9 3) instance on AWS and using Putty have access - Meanwhile it turns out I have the same issues with all 3 browsers - but now it also happens when I save a new field, F12:

        unreachable code after return statement[Learn More] espo.min.js:201:12
        unreachable code after return statement[Learn More] espo.min.js:201:12

        SecurityError: Permission denied to access property "dispatchEvent" on cross-origin object inject.js:65
        onUserInput/< moz-extension://ec1a4bbd-ad6b-4c1c-b2e7-4602a40397ed/js/inject.js:65:9
        forEach self-hosted:273:13
        onUserInput moz-extension://ec1a4bbd-ad6b-4c1c-b2e7-4602a40397ed/js/inject.js:64:7
        onUserInput self-hosted:994:17
        onKeyUpMouseUpTouchEnd/< moz-extension://ec1a4bbd-ad6b-4c1c-b2e7-4602a40397ed/js/inject.js:58:9

        Bad server response: espo.min.js:667:25
        setupAjax/</sdespo/client/espo.min.js:667:25
        dispatch /sdespo/client/espo.min.js:3:38208
        add/r.handle /sdespo/client/espo.min.js:3:35024
        trigger /sdespo/client/espo.min.js:3:37361
        x/sdespo/client/espo.min.js:3:74993
        b/< /sdespo/client/espo.min.js:3:78427
        Server side error 500: Error while rebuilding database. See log file for details. espo.min.js:716:21
        setupAjax/< /sdespo/client/espo.min.js:716:21
        dispatch /sdespo/client/espo.min.js:3:38208
        add/r.handle /sdespo/client/espo.min.js:3:35024
        trigger /sdespo/client/espo.min.js:3:37361
        x /sdespo/client/espo.min.js:3:74993
        b/< /sdespo/client/espo.min.js:3:78427

        This is on a fresh Bitnami instance, created last night, haven't made any changes and Admin is the only user

        Any ideas regarding "unreachable code"? Learn More eludes to a missing
        (Attachment)
        Attached Files

        Comment


        • #5
          If this is happening with a fresh instance without modifications (nothing to do with possible custom code changes) ,in a new server (AWS Bitnami instance - nothing to do with server issues or sever settings issues) and with 3 different browsers (not a Firefox, Chrome or Edge issues) I really don't know how this is being triggered.

          Could it be some type of virus protection or other software blocking access on the local machine or something to do with your local LAN / Router ?. Maybe do a "desperation" move and try with another machine from a different LAN.

          yurikuzn , tarasm or Maximus would you have any suggestions ?
          Last edited by telecastg; 08-03-2020, 09:40 PM.

          Comment


          • #6
            It sound like you got it working before but then went into this black hole after doing mortification?

            If that is right then it always a hassle to pinpoint the culprit, especially if you have little troubleshoot or debugging skill. If sure if it help you but one suggestion I recommend to do is to start renaming your folder (especially custom folder) and see if it functioning (e.g. can log in and be able to use espocrm, it just might look weird and fail to do advance task).

            I post a couple of thread where I went into panic mode and start renaming/deleting folder to find out the issue.

            I would suggest that is one method that I would employ. With regard to SSH, you shouldn't need to use it, use your CPanel File Manager to access the EspoCRM folder. I find it easier that way (because I'm a GUI level of user).

            Secondly is to compare the original file vs your file, for example you see the error got to do with some file call "espo.min.js" then you would compare that and just to be safe, rename your file and upload the original file.

            As for it being a Bitnami, that might pose of an issue in term of getting helps. If you on shared hosting AWS I thought you can use Docker package? If it normal hosting you might be able to use Softalicious to install.

            Comment


            • #7
              Another option that came to mind is to download and install a fresh instance into a local server (xampp), make sure is running without any issues and then download from your cloud server the "custom" folders only (custom/Espo/Custom and client/custom) which is where Espo stores all custom modifications and copy those folders to your local instance to test those modifications.

              This option will at least tell you if it's really an issue of code (standard or custom) and not an issue having to do with the cloud setup or your lan setup.

              By the way, if you are not doing it already, I strongly recommend that you set up a local server to always test any changes and to use git to be able to reverse them and when you are happy with them, then upload the "custom" folders (or if you modify any "standard" files) to your cloud instance.

              Comment


              • #8
                Ok to update: I think it was an extension on my browser (waterfox) or the browser itself - I had read the cross script error was a browser handling issue, so I cleared everything I could think of rebooted and now I have no error showing up when I clear cache or rebuild with my shared server version of Espo or the AWS version.

                Sorry for all the crazyness but I am grateful for all the above suggestions and troubleshooting; you both are very helpful!

                Btw, my host did approve me for SSH access. I originally wanted it because clear cache/rebuild didn't seem to work and I thought using CLI would (some files say "only CLI"). I would add a field and it wouldn't show up w/o clicking over and over but that seems to have gone away now.

                Comment


                • #9
                  I'm glad that is over and thanks for posting the solution. This will help someone else having a similar issue in the future.

                  Comment

                  Working...
                  X