Announcement

Collapse
No announcement yet.

EspoCRM wont fetch sent Mails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EspoCRM wont fetch sent Mails

    for Some reason my EspoCRM wont fetch sent mails from imap host anymore.

    I searched in logs for reason, but cant find one.
    Cron is working fine - it is fetching inbox mails fine too.

    tried with differnt imaphosts too. (one ist gmail).

    Does anyone have an idea?

  • #2
    Hello,
    I have tested IMAP fetching from GMAIL host and it works good.
    ould you provide the next information:
    1. Steps to reproduce;
    2. Screenshot whit your IMAP settings;
    3. Do you have any email filter in EspoCRM?
    4. What EspoCRM version do you use?

    Comment


    • #3
      1. i did nothing special. It doenst make an difference which kind of imap konto i add. For another user the same issue exists (tried with different mailboxes too).
      2.
      Click image for larger version

Name:	tempsnip.png
Views:	81
Size:	71.2 KB
ID:	52893
      ... it doenst work with local IMAP-Mailbox too.


      3. no, i dont use any e-mail filter
      4. i Use recent version (5.7.6)

      Thanks for u help
      (btw. Mailbox server doenst give bad logs, espocrm logs are emtpy too)

      Comment


      • #4
        On your screenshot, I see that your IMAP connection monitors and fetches email from the 'INBOX' folder only, but stores all sent emails in the [Gmail]/Gesendet.
        Please, add the [Gmail]/Gesendet folder to monitored folders.

        Comment


        • #5
          I tried to add my sent folder, but i only get an error (screenshot: )
          for adding i used the up arrow and "choosed" that sent folder. After that i pressed save
          Attached Files

          Comment


          • #6
            Could you provide the error description from the error log file (see /data/logs)?

            Comment


            • #7
              i tried to reproduce it, but there isnt come up a new log file (with Date of Today). but here the logs from yesterday:

              espo@espocrm:/var/www/html/espocrm/data/logs$ cat espo-2019-10-29.log
              [2019-10-29 12:51:32] Espo.DEBUG: Schema\Converter - Start: building schema [] []
              [2019-10-29 12:51:32] Espo.DEBUG: Schema\Converter - End: building schema [] []
              espo@espocrm:/var/www/html/espocrm/data/logs$ cat espo-2019-10-28.log
              [2019-10-28 11:05:15] Espo.DEBUG: API (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; Route pattern: /:controller; Route params: Array ( [controller] => Email ) [] []
              [2019-10-28 11:05:15] Espo.ERROR: (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; line: 132, file: /var/www/html/espocrm/application/Espo/ORM/DB/Mapper.php [] []
              [2019-10-28 11:05:18] Espo.DEBUG: API (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; Route pattern: /:controller; Route params: Array ( [controller] => Email ) [] []
              [2019-10-28 11:05:18] Espo.ERROR: (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; line: 132, file: /var/www/html/espocrm/application/Espo/ORM/DB/Mapper.php [] []
              [2019-10-28 11:05:23] Espo.DEBUG: API (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; Route pattern: /:controller; Route params: Array ( [controller] => Email ) [] []
              [2019-10-28 11:05:23] Espo.ERROR: (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; line: 132, file: /var/www/html/espocrm/application/Espo/ORM/DB/Mapper.php [] []
              [2019-10-28 11:05:26] Espo.DEBUG: API (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; Route pattern: /:controller; Route params: Array ( [controller] => Email ) [] []
              [2019-10-28 11:05:26] Espo.ERROR: (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; line: 132, file: /var/www/html/espocrm/application/Espo/ORM/DB/Mapper.php [] []
              [2019-10-28 11:05:31] Espo.DEBUG: API (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; Route pattern: /:controller; Route params: Array ( [controller] => Email ) [] []
              [2019-10-28 11:05:31] Espo.ERROR: (42S22) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'usersMiddle.is_read' in 'where clause'; GET /espocrm/api/v1/Email?folderId=drafts&select=personStringData%2Csu bject%2CparentId%2CparentType%2CparentName%2CdateS ent&maxSize=20&offset=0&orderBy=dateSent&order=des c&where%5B0%5D%5Btype%5D=isFalse&where%5B0%5D%5Bat tribute%5D=isNotRead; line: 132, file: /var/www/html/espocrm/application/Espo/ORM/DB/Mapper.php [] []
              [2019-10-28 13:09:56] Espo.INFO: AUTH: Trying to login as user 'timo' by token but token is not found. [] []
              [2019-10-28 13:09:57] Espo.INFO: AUTH: Trying to login as user 'timo' by token but token is not found. [] []
              espo@espocrm:/var/www/html/espocrm/data/logs$


              Comment


              • #8
                I don't see the description of that error. I only see the problem with the 'usersMiddle.is_read'. Is this your custom filter?
                I have checked it on my instance and it works w/o any problem.
                Could you try to reproduce this error again and check for the error description again?

                Comment


                • #9
                  i can reproduce it, but i am gettin no new erros in log files.
                  for some reason i found some log entry now from this morning (ca. 1 hour after i tested it to make post from above)
                  "
                  [2019-10-30 09:49:06] Espo.ERROR: EmailAccount 5db3839aebec7e049 (Select Folder) [0] cannot read - connection closed? [] []
                  "

                  > I don't see the description of that error. I only see the problem with the 'usersMiddle.is_read'. Is this your custom filter?
                  i didnt defined an custom filter yet.

                  Comment


                  • #10
                    I can confirm that this si happening to me after upgrading to version 5.7.6 the emails won't be fetched and also have more issues with Access Roles. Hope they will fix this soon.

                    have you found a work around to fetch the email yet ?

                    Thanks

                    Comment


                    • #11
                      Hello Rabii,
                      i dont have an workaround yet. I am thinkig about to add it in database manuell (but didnt had time yet to do this).
                      unfortunatly i have no idea where this issue comes from (because it worked sometime, because old e-amils are fetched)

                      Comment


                      • #12
                        Hello Rabi,
                        now i changed it MySQL-Database via MySQLWorkbench (see Attachment). Worked for me (so i am able to fetch sent mails now).

                        Comment

                        Working...
                        X