Announcement

Collapse
No announcement yet.

Knowledge base search no longer searches folders

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Knowledge base search no longer searches folders

    I noticed about two months ago that the KB search stopped returning results if the articles were in folders. Is that the intended behavior? It used to be that every article was listed in the KB section by default and then the list could be filtered by clicking on folders. Now it's the opposite: no articles are shown unless I click on a folder/category that has been explicitly added to the individual article. That makes the search function very difficult to understand for users. The way it was before worked very well: every article was shown and searched by default and categories could optionally be added for better organization. How do I get that functionality back?

    I'm using Espo 5.0.1 and I think this started happening around 4.8.4 or possibly a little earlier. I did not modify any files or behaviors. It was due to an upgrade to the core software.
    Last edited by bandtank; 01-08-2018, 04:58 PM.

  • #2
    You can expand folder contents by clicking on the folder icon. State will be stored so no need to click every time.

    Click image for larger version  Name:	kb.png Views:	1 Size:	11.4 KB ID:	33574
    Last edited by yurikuzn; 01-08-2018, 07:02 PM.

    Comment


    • #3
      Perfect. Thanks.

      Comment


      • #4
        yurikuzn is there a way to have the default behavior to search inside of all folders for the query?

        We are having a lot of problems finding articles now.

        Comment


        • #5
          The default behavior shouldn’t really matter because the open/close setting persists once it has been changed. Why can’t you teach your users about it? I sent an email to explain how it works and that was the last time I heard a complaint.

          Comment


          • #6
            bandtank can you share the email if it can help with search. Right now the KB is basically useless without search.

            Comment


            • #7
              Actually, I am seeing a slightly odd behavior that makes searching somewhat difficult. I have an article called "How to send and receive a fax," which I have been unable to find recently.

              In my config.php file, I have the following settings:
              Code:
              'textFilterUseContainsForVarchar' => true
              'fullTextSearchMinLength' => 2
              I added Name to the Knowledgebase Article entity definition's Text Filter Fields list and I enabled Full Text Search as well.

              Here's what happens when I try to search in the KB article search box:

              Code:
              Article name: How to send and receive a fax
              
              Search Term     Article Found
              fax             no
              a fax           no
              receive a fax   yes
              eceive a fax    no
              ceive a fax     no
              eive a fax      no
              ive a fax       no
              ve a fax        no
              e a fax         no
               a fax          no
              a fax           no
               fax            no
              fax             no
              ax              no
              x               no
              %receive a fax  yes
              %eceive a fax   no
              %ceive a fax    no
              %eive a fax     no
              %ive a fax      no
              %ve a fax       no
              %e a fax        no
              % a fax         no
              %a fax          no
              % fax           no
              %fax            yes
              %ax             yes
              %x              yes
              Using Name -> Contains -> fax works as expected, but that's a lot more effort and shouldn't be necessary.

              This makes searching quite difficult. I'm not sure if this behavior changed recently, but I'm not sure how to fix it. The behavior is not related to folders as it happens at any search level in my KB.

              Shouldn't the search simply work like this?
              Code:
              %<input>%
              Last edited by bandtank; 07-11-2018, 10:31 PM.

              Comment


              • #8
                I am noticing the same which makes search basically useless.

                Comment


                • #9
                  1. Mysql has own parameter ft_min_word_len you can change.
                  2. If your table is myisam and mysql is 5.7, try to convert to innodb.

                  Comment


                  • #10
                    3. Use * wildcard for text filters.

                    Comment


                    • #11
                      4, No need to enable full-text search unless you have thousands of records or want to use search operators: https://github.com/espocrm/documenta...ll-text-search.

                      Comment


                      • #12
                        I updated the KB article table to InnoDB, EspoCRM to 5.3.2, and I changed the ft_min_word_len parameter to 3. I still can't find the fax article using only the word fax. The only way I can get it to work is to do what's in the attached picture. After making that change, my KB searches are exactly what I would expect.
                        Last edited by bandtank; 07-12-2018, 02:43 PM.

                        Comment


                        • #13
                          Did you rebuild?

                          Comment


                          • #14
                            Originally posted by yurikuzn View Post
                            Did you rebuild?
                            Yes. I cleared the EspoCRM cache, my local cache, used a private browsing window, and rebuilt the database multiple times before and after all of those steps.

                            It's actually still not working right. It's better, but I'm seeing behavior that doesn't make sense. I expect the search to return results for partial strings in titles and bodies, but it seems to only work when the word is a complete word, which I don't understand. See this video.

                            Comment


                            • #15
                              I tested with

                              textFilterContainsMinLength => 3

                              and it worked fine.

                              Comment

                              Working...
                              X