Internal server error

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • ferradeira
    Member
    • Apr 2026
    • 68

    #1

    Internal server error

    There is a couple of contacts when I tried to add it in Opportunities I get this error:
    Internal server error

    Check logs for details.

    Cannot find anything in data/logs. Where should I look?
  • victor
    Active Community Member
    • Aug 2022
    • 1246

    #2
    - Enable Debug mode: https://docs.espocrm.com/administrat...ng/#debug-mode.
    - Reproduce the error.
    - Provide part of the log with this error. EspoCRM log files are located in {ESPO_ROOT}/data/logs/ directory. Most errors are logger there.

    Also, please let me know if the error occurs when you add just one contact to an Opportunity, or specifically when adding multiple contacts.

    Comment

    • ferradeira
      Member
      • Apr 2026
      • 68

      #3
      I don't understand why the LOG shows a time that's one hour behind the system time.

      I don't know where is this column c_contact_phone.

      I have 3 contacts I can add to this opportunity, but only one I can save.

      [2026-09-23 15:23:34] DEBUG: API (22001) SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'c_contact_phone' at row 1; PUT /Opportunity/6aa3d9abb15d6e9b6; Route pattern: /{controller}/{id}; Route params: Array ( [controller] => Opportunity [action] => update [id] => 6aa3d9abb15d6e9b6 )
      [2026-09-23 15:23:34] CRITICAL: (22001) SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'c_contact_phone' at row 1 :: PUT /Opportunity/6aa3d9abb15d6e9b6
      [object] (PDOException(code: 22001): SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'c_contact_phone' at row 1 at /var/www/espocrm/application/Espo/ORM/Executor/DefaultSqlExecutor.php:77)

      Comment

      Working...