No announcement yet.

Espo adding a 'C' before my entity names

  • Filter
  • Time
  • Show
Clear All
new posts

  • Espo adding a 'C' before my entity names

    Whenever am creating a new entity in the entity manager, I get a letter added to the start of my entity Name.

    For example, the I create an entity named 'Test', when I click on Create button, the entity that is created is 'CTest'

    I have created many other entities in the past in the same instance, I have checked if there is a duplicate entity name, I have tried many names with the same result.

    is it a bug?

    espocm version: 8.2.2
    php version: 8.1
    DB: MariaDB​

  • #2
    Hi Emmker,

    It is a new feature of EspoCRM v8.2:


    • Emmker
      Emmker commented
      Editing a comment
      I see.. Thank you, thought I was going mad for a minute.

  • #3
    I thought about one question regarding this.
    Sometimes you have to use the entity name in formulas, relationship names etc.. Will I have to put the c in front as well? What about formulas created before this feature was added. Will I have to adapt all formulas, where the entity does not have the c in the name?


    • espcrm
      espcrm commented
      Editing a comment
      All new field will required it. In a way it not too bad of a change. Now that I know it add a c, whenever I use formula related to my custom field I just type c and go from there. It will not mix with original field.

      However like many people, we still have custom field at the moment without c, so it a mixed bag.

  • #4
    Nothing needs to be fixed.


    • #5
      Hi, the idea behind the "C" makes sense, and I like it.

      Here is my question:
      How do I add it to all of the entities I have previously created?


      • espcrm
        espcrm commented
        Editing a comment
        I recommend just keep it as is honestly, else you will run into error because you forgot to fix some Formula, Workflow, etc.

    • #6
      Hi, There's no simple way to convert fields and links other than manually.

      There's a command that renames a custom entity type. Make a backup before running.