Announcement

Collapse
No announcement yet.

Dynamic Checklist for EspoCRM 7.3.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynamic Checklist for EspoCRM 7.3.0

    Hello Guys,

    I updated telecastg Dynamic Checklist extension to support Espo 7.3.0 new checkbox style.
    Click image for larger version  Name:	image.png Views:	0 Size:	11.0 KB ID:	87592​​
    You can download the update from my github repo.

    EspoCRM extension that adds a custom type field which allows to dynamically create a checklist inside any EspoCRM entity - Kharg/dynamic-checklist-for-espocrm
    Last edited by Kharg; 01-29-2023, 04:04 AM.

  • #2
    Just updated to version 2.2.0 with option to strike checked items.
    EspoCRM extension that adds a custom type field which allows to dynamically create a checklist inside any EspoCRM entity - Kharg/dynamic-checklist-for-espocrm


    Click image for larger version  Name:	image.png Views:	434 Size:	8.2 KB ID:	91012
    Last edited by Kharg; 12-15-2023, 11:14 PM.

    Comment


    • espcrm
      espcrm commented
      Editing a comment
      Cool, from that screenshot, you reckon it (the strike) could be slightly lower or higher? the "-" in the E sorta disappear with the current strike line. But I have feeling this is render by whatever Browser you are using so it is impossible.

    • Kharg
      Kharg commented
      Editing a comment
      It's using CSS to strike the text, I could've done using html strike tags as well, but the result would've been the same. I don't think there's a way to move the strike line

  • #3
    Reposting here:

    Very cool. Was looking if there was solution to create a check list from predefined options for the checklist and found this.

    If you want to add a german translation, here is the code.

    files/application/Espo/Modules/DynamicChecklist/Resources/i18n/de_DE/Admin,json

    Code:
    Code:
    {
    "fieldTypes": {
    "dynamic-checklist": "Dynamische Checkliste​"
    },
    "fields": {
    "strikeChecked": "Markierte Einträge durchstreichen"
    }
    }​​​​​

    Comment


    • #4
      However this seem not to work anymore with EspoCRM version 8.0.1

      I can not click on edit and this is the error message in the browser console: Uncaught (in promise) TypeError: this.escapeValue is not a function​

      getItemHtml dynamic-checklist.js:78
      data dynamic-checklist.js:49
      data dynamic-checklist.js:48
      ...

      Comment


      • Kharg
        Kharg commented
        Editing a comment
        Thanks for reporting, will check the issue and fix it as soon as possible

        If you could open an issue on the github it would be better

    • #5
      Kharg seem to be disabled for New Issue?
      Click image for larger version

Name:	image.png
Views:	394
Size:	14.2 KB
ID:	97562

      Comment


      • Kharg
        Kharg commented
        Editing a comment
        ohh, must be because it's a fork.

      • ThomasB
        ThomasB commented
        Editing a comment
        No, go to settings of your project and then under features check mark Issues.

      • Kharg
        Kharg commented
        Editing a comment
        Done, thanks.

    • #6
      ThomasB espcrm update released.

      Comment


      • #7
        Thanks, I updated it and it works again.

        Comment


        • Kharg
          Kharg commented
          Editing a comment
          I released a new update fixing some more issues.

        • ThomasB
          ThomasB commented
          Editing a comment
          Already installed.

      • #8
        Logged in to say thank you for keeping this extension active and working 2.2.2 fixed it for EspoCRM 8.0.x

        Comment


        • Kharg
          Kharg commented
          Editing a comment
          I am glad it to hear this

      • #9
        is the error message in the browser console:
        Attached Files

        Comment


        • Kharg
          Kharg commented
          Editing a comment
          update the extension to the latest version

      • #10
        I already have the latest version 2.2 but I still get the error

        Comment


        • Kharg
          Kharg commented
          Editing a comment
          Are you using it with Espo 8.0?

      • #11
        8.0.3

        Comment


        • #12
          Click image for larger version

Name:	image.png
Views:	233
Size:	24.0 KB
ID:	99821
          I also have an issue - nothing happens when I click on the field, and there is an error in the console. Plugin version is 2.2, system version is 8.0.3.

          Comment


          • #13
            I also have an issue
            system version 8.0.6

            Comment


            • #14
              Version 2.2.2 is working fine for me on 8.0.6

              Can you exactly tell me what you are doing to get the error? Exact steps to reproduce please

              BigBoss slavin3000 abidoss

              Comment


              • slavin3000
                slavin3000 commented
                Editing a comment
                Thanks it works

            • #15
              It's good for me, I uninstalled the extension, deleted it, and I'm going to reinstall it.

              Comment

              Working...
              X