Announcement

Collapse
No announcement yet.

Getting 500 error after trying to install Mailchimp extension

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting 500 error after trying to install Mailchimp extension

    Having a really hard time getting Espo set up and running.

    I have just set up a fresh install of Espo 7.3.2. After much battling with my Nginx file I finally got it working. I then needed to add extensions and I uploaded the latest Outlook extension with no problem. I then tried to upload the Mailchimp extension (we have version 1.0.5 - I can't tell from the change log if that is the latest version or not?). It said it had installed successfully but I am now getting a blank page when I try and load the system with an Error 500 message at the top.

    There is nothing new in data > logs and below is what I'm seeing in my console:

    Click image for larger version  Name:	image.png Views:	0 Size:	29.4 KB ID:	87466

    I have tried running rebuild.php and clear_cache.php from the CLI but that hasn't helped.​
    Last edited by Hannah; 01-25-2023, 10:48 AM.

  • #2
    Hi Hannah,
    Run command

    php command.php extension -u --name="Extension Name"
    To unistall the extension.

    MailChimp 1.0.5 isn't the latest extension version. Can you check on your Espocrm Portal if a new version is available?

    Comment


    • #3
      Thank you Kharg


      Do you know how I work out exactly what the name of the extension is? I've tried "mailchimp", "MailChimp", "mail-chimp-integration-1.0.5" and "mail-chimp" but it says for both of these that that extension doesn't exist.

      If I go to application>Espo>modules I see the following, so I know it's still installed:

      Click image for larger version

Name:	image.png
Views:	208
Size:	25.1 KB
ID:	87475
      Last edited by Hannah; 01-25-2023, 12:31 PM.

      Comment


      • #4
        Hi Hannah,

        it should be "MailChimp Integration"

        php command.php extension -u --name="MailChimp Integration"


        Also latest version available working with Espo 7.3.2 should be MailChimp Integration 1.0.9
        Last edited by Kharg; 01-25-2023, 12:35 PM.

        Comment


        • #5
          That's brilliant and it's worked, thank you so much Kharg

          Comment


          • Kharg
            Kharg commented
            Editing a comment
            I am glad it worked
        Working...
        X