Announcement

Collapse
No announcement yet.

Free Extension: Espo Plus

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Free Extension: Espo Plus

    I am appreciated to announce my free extension "Espo Plus" by Eblasoft, and planned to add more features in the future.

    Current version: 1.1.0
    Product details: from here ...
    Current Functions:
    1. Contacts new mass action "Send Mail".
    2. Enum: show as button group.
    Click image for larger version

Name:	Screen Shot 2020-06-07 at 1.43.26 PM.png
Views:	1599
Size:	46.7 KB
ID:	59193
    Eblasoft Ltd.
    eymen@eblasoft.com.tr
    See our extensions

  • #2
    thanks you!

    Comment


    • #3
      Cool. Tried it. It look bit off once you have more than 3 fields. Especially if you have bit longer text, but that no matter. More concerning is, I think I found a bug.

      I can't set my Status for my meeting unless I enable the Group Buttons after installing Espo Plus 1.1.0, it will keep reverting back to default (Planned).

      For Meeting Status I kept the Group Button (Espo Plus) disable and used the default drop down menu, after changing the Status (Held) and saving it won't save.

      Comment


      • #4
        Originally posted by espcrm View Post
        Cool. Tried it. It look bit off once you have more than 3 fields. Especially if you have bit longer text, but that no matter.
        First of all thanks to give it a try and more thanks to give me some of your time fir your valuable feedback, yes this feature is good for some use cases and not for all enumns,
        It's still fresh and will has many updates later, for example having dropdown for the overflow options.


        Originally posted by espcrm View Post
        More concerning is, I think I found a bug.

        I can't set my Status for my meeting unless I enable the Group Buttons after installing Espo Plus 1.1.0, it will keep reverting back to default (Planned).

        For Meeting Status I kept the Group Button (Espo Plus) disable and used the default drop down menu, after changing the Status (Held) and saving it won't save.
        I will reproduce this issue, fix and upload the update. Thank you!


        UPDATE:
        New update 1.1.2 has just released fixing the issue, thanks again.
        Last edited by eymen-elkum; 06-08-2020, 05:05 AM. Reason: announce the fix release
        Eblasoft Ltd.
        eymen@eblasoft.com.tr
        See our extensions

        Comment


        • #5
          The possibility of a mass email to portal users would be very good.

          Comment


          • eymen-elkum
            eymen-elkum commented
            Editing a comment
            I will add this and update here

        • #6
          Update: Solution is in my comments. I will wait to confirm if is this an isolated bug (just my system) or a bug in general before installing again.

          Not sure if it just me but now I'm having issue after the update.

          After installation I notice a "Maintenance mode" activate, it look like extension installation failed mid-way and this two mode was not disable. So I went to Admin/Setting to disable but no matter what I try I can't get access to it.

          Clean Cache, Rebuild, Checked logs, check cache folder. Used a fresh new internet browser. Still failing to access it. Uninstall extensions (noticed that 1.1.1 was still in the system, and an 1.1.2 is installed also). Uninstall 1.1.1. Try again. Uninstall 1.1.2 still not working.

          Console showing this as a possible reason: TypeError: data.translatedOptions is null

          Sound like it some translated or language issue? I will try to go from there.

          ---

          Check the console further and it seem to be related to this:

          Code:
          Espo.define('espo-plus:views/fields/enum', 'views/fields/enum', function (Dep) {
          return Dep.extend({
          
          // editTemplate: "espo-plus:fields/enum",
          
          events: _.extend({
          'change input': function (e) {
          var value = $(e.target).val();
          this.model.set(this.name, value);
          }
          }, Dep.prototype.events),
          
          _getTemplateName: function () {
          if (this.mode === 'edit' && this.params['showAsButtonGroup']) {
          return 'espo-plus:fields/enum';
          }
          return Dep.prototype._getTemplateName.call(this);
          },
          
          data: function () {
          var data = Dep.prototype.data.call(this);
          
          data.buttons = data.defs.params.options.map(function (option) {
          return {
          key: option,
          style: this.styleMap[option],
          text: data.translatedOptions[option]
          }
          }.bind(this));
          
          return data;
          },
          
          fetch: function () {
          if (this.params['showAsButtonGroup']) {
          var data = {};
          data[this.name] = this.$el.find('input:checked').val();
          return data;
          }
          
          return Dep.prototype.fetch.call(this);
          }
          })
          });
          Or more specifically something to do with this?

          Code:
          data: function () {
          var data = Dep.prototype.data.call(this);
          
          data.buttons = data.defs.params.options.map(function (option) {
          return {
          key: option,
          style: this.styleMap[option],
          text: data.translatedOptions[option]
          }
          }.bind(this));
          
          return data;
          },
          I'm not sure but maybe Espo Plus button is trying to make some Admin/setting field into a group button and it causing this error?

          Also tried to install v1.1.0 to see if that disable the button somehow but no luck either.
          Last edited by espcrm; 06-10-2020, 02:17 AM.

          Comment


          • espcrm
            espcrm commented
            Editing a comment
            OK Update. Solution to fix my issue is below.

            Move or delete the folder: EspoPlus in
            application\Espo\Modules\
            client\modules\

            And a learning process post: https://forum.espocrm.com/forum/gene...9249#post59249

          • eymen-elkum
            eymen-elkum commented
            Editing a comment
            Just to clear,

            The issue you faced is related to my extension and not related of espocrm, normally when the user faces such a problem he just tell the developer and he replay with fix release.

            Installing the new version will fix it completely.

            The extension is safe upgrade, means there is no any change to the espo files, IOW deleting the folder EspoPlus is just like safe uninstalling of the ext

          • espcrm
            espcrm commented
            Editing a comment
            I understand. Usually I need to make sure it is related to extensions and not risk falsely making incorrect statement as not to offend.

        • #7
          Hi espcrm , I have just upload the last version to the web store, last 2 days had a lot of releases some was for fix and some was features.

          Your issue must be fixed.

          Sorry for the time you spent and thank you.
          • espo-plus-1.0.0: (23.05.2020)
            - contact "send mail" mass action
          • espo-plus-1.1.0: (07.06.2020)
            - enum field as group button
          • espo-plus-1.1.1: (07.06.2020)
            - apply the button group template only if enabled from field manager
          • espo-plus-1.1.2: (08.06.2020)
            - fix bug on fetch value when feature not enabled
          • espo-plus-1.1.4: (08.06.2020)
            - option for enable the toggle buttons group even on read mode
          • espo-plus-1.1.5: (08.06.2020)
            - fix enum-plus not work on search filter
          • espo-plus-1.1.6: (08.06.2020)
            - disable buttons for list
          • espo-plus-1.1.8: (08.06.2020)
            - enum-plus text overflow fix
          • espo-plus-1.1.9: (08.06.2020)
            - fix bug
          • espo-plus-1.1.9: (08.06.2020)
            - fix translation
          • espo-plus-1.1.10: (08.06.2020)
            - buttons colors
          • espo-plus-1.2.0: (08.06.2020)
            - buttons separated
          Last edited by eymen-elkum; 06-10-2020, 03:16 AM.
          Eblasoft Ltd.
          eymen@eblasoft.com.tr
          See our extensions

          Comment


          • espcrm
            espcrm commented
            Editing a comment
            That huge update. Downloading.

            Looking good, the bug is gone. Also notice that the button no longer cut off (cool). Look very nice. Just using it for Meeting at this stage until I can think of more way to use it.

            I know that whichever button you select the text will be bold, but it bit difficult to see. Is it possible to make it more visible which is selected?
            Perhaps a font color change or border of the button, not sure.

            (Now I'm just being a nuisance): requesting for support of Multi-Enum.
            Last edited by espcrm; 06-10-2020, 04:22 AM.

          • eymen-elkum
            eymen-elkum commented
            Editing a comment
            I will consider improving it for multi enum in the nearest time, the time is full of tasks for a while.

        • #8
          I recently noticed shrinking Width (right side of view), I believe it is related to EspoPlus. Not sure if you run into this issue yet, I'm not quite sure how to produce it but here goes.

          I been creating new Contact lately (none of the Contact field have Button enable though). Sometime I create by Duplication, sometime through Quick Create top right button, sometime but the Create New Contact on listing.

          After making it I might link it to an account, or another relationship (property mainly).

          Slow over the course of hours the width of my Contact shrink on the right hand side. It eventually get smaller and smaller so I just refresh the page and it back to normal, until later it start again. I did a CSS check to see if there any element name to it but I can't select it. Hovering over it does have a name though, "body.minimized", not sure if that will help.

          As long as I don't refresh the tab, changing view to any entity or record view will still have to bar. If there is a produce-able method I will post again.

          Comment


          • eymen-elkum
            eymen-elkum commented
            Editing a comment
            Thanks for the report,

            There is no additional css script on EspoPlus, or any affects to the view outside the target enum field.

            I believe you have some custom script or css that causes this issue, if you could re-produce this issue I will appreciated to see it.

            My client is using this feature actively and not raised such problem.

            Best Regards

          • espcrm
            espcrm commented
            Editing a comment
            Thank ayman, glad to hear no one have an issue.

            Once I figure out what trigger it I will report back.

            I do have a CSS that affect it (small chance), it the Email colours CSS code you provided in another thread. I believe it might be due to some way I set up my CRM.

        • #9
          I finally manage to figure out how to reproduced it. I wanted to see if I can reproduce on your demo server but it require password and username now? http://demo.ebla-soft.com

          But I thought, maybe it is not EspoPlus and it is EspoCRM itself. So I went and decide to test it on the (official) Demo server. And the culprit is found!

          It is not related to EspoPlus. It is related to a new function that recently been added. I will report the bug in another thread.
          Last edited by espcrm; 06-24-2020, 08:42 AM.

          Comment


          • tothewine
            tothewine commented
            Editing a comment
            for completeness.. can you link the bug here?

          • espcrm
            espcrm commented
            Editing a comment
            tothewine I posted it in this thread here: https://forum.espocrm.com/forum/bug-...m-sidebar-view

            Since it wasn't relevant to EspoPlus I didn't consider linking it here. Yurikuzn said Thanks as acknowledgement but I haven't seen an Issue made on Github for that yet, maybe it was a silent fix.

            I will test it in future and complain again if it still there

          • tothewine
            tothewine commented
            Editing a comment
            good thanks

        • #10
          New version just released ! 1.4.0
          Eblasoft Ltd.
          eymen@eblasoft.com.tr
          See our extensions

          Comment


        • #11
          Just gave new version I try, look like you put a "Black Border" around selected Group Button. Looking good

          Comment


          • eymen-elkum
            eymen-elkum commented
            Editing a comment
            thank you for the review

        • #12
          how to download?

          Comment

        Working...
        X