Users do not see attachments in the Stream (updating to 7.5.1)
Collapse
X
-
thanks everyone, you are the bestThis issue will be fixed in EspoCRM v7.5.2: https://github.com/espocrm/espocrm/issues/2770. -
This issue will be fixed in EspoCRM v7.5.2: https://github.com/espocrm/espocrm/issues/2770.Leave a comment:
-
-
have a look at the Download.php and compare it with current stable version.Leave a comment:
-
log error (previously none)
WARNING: (403) GET /CRM/; line: 69, file: /home/today/i.today/www/CRM/application/Espo/EntryPoints/Download.phpLeave a comment:
-
on the user's side in the browser log:
GET CRM/?entryPoint=image&id=648ad525101cbf510 403 Forbidden
Failed to load content for CRM/client/lib/original/jquery.js (Error HTTP. Status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE.).Leave a comment:
-
looks normal, do you have anything in the log ? check the log and see what message it displays thereLeave a comment:
-
no, just this
custom/Espo/Custom/Resources/metadata/entityDefs/Note.json
PHP Code:{ "fields": { "attachments": { "sourceList": [ "Document" ], "maxFileSize": 5, "accept": [ "image/*", "audio/*", "video/*", ".zip", ".pdf", ".odt", ".ods", ".odp", ".docx", ".xlsx", ".pptx", ".doc", ".xls", ".ppt", ".rtf", ".csv", ".md", ".txt" ] } }, "links": { "attachments": { "type": "hasChildren", "entity": "Attachment", "foreign": "parent", "layoutRelationshipsDisabled": true, "relationName": "attachments", "disabled": true } } }Leave a comment:
-
Do you have any custom code / function for the note entity ? i have tried it again on a new instance and everything works fine, this could be caused by some custom code you have on your instance.Leave a comment:
-
-
try another file type of pdf to see if issue is with type (also check what are the file extensions allowed for the attachments field on the note entity.Leave a comment:
-
already checked, I agree it's strange, I can't understand how it works, on the user's side
"403 Forbidden" - No access to attachmentLast edited by alexisc; 06-15-2023, 09:46 AM.Leave a comment:
-
that is weird i have just tried it and it works. try to log in as user and check from their session what happens.Leave a comment:
-
Thank you for your attention to my problem!
1. I checked the necessary permissions - everything is ok
2. Hard Rebuild - did not, I do not think that this will solve the problem. Everything worked before the update.
Users don't have access to the files only if I post a "to all internal users" message.
If "to particular user(s)" is set, everything works.Leave a comment:

Leave a comment: