No announcement yet.

Access checker is not implemented - Error Espocrm version 7.0.8

  • Filter
  • Time
  • Show
Clear All
new posts

  • Access checker is not implemented - Error Espocrm version 7.0.8


    I have made an update from version 6.1.10 to 7.0.8. Since then I am not able to log in as a user (only admin works). I get the following error in the log:

    [2021-10-31 12:40:37] ERROR: (0) Access checker is not implemented for 'Holiday'.; GET /Metadata; line: 88, file: /var/www/espocrm/application/Espo/Core/Acl/AccessChecker/AccessCheckerFactory.php [] []

    Two weeks ago, as part of the update to Debian 11, I changed the PHP version from 7.3 to 7.4. After that, everything ran normally for the last two weeks.

    My system is running the Advanced-Pack 2.8.6 and the Sales Pack 1.4.4

    I already searched the forum for the error and found the problem with the custom hooks. I think it does not affect me. I created the entity "Holiday" as administrator via the entity manager and no error was shown there. Maybe someone has an idea what to do or where I can adjust something?

    Thank you.

  • #2
    you have certainly a something bad with 'Holiday' entity,
    (1) check in metadata/entityDefs/ .... all entity in relation with Holiday.. remove bad line

    you can too create a metadata/scope/Holiday.json (duplicate another and change according value) but the best is search (1)


    • #3
      Hi there,

      thanks for the hint with the path, that solved my problem.

      I used the grep function to search in the metadata/entityDefs/ directory for the word. Then I edited the entity via the administration GUI (Entity-Manager). Afterwards the new version 7.0.8 worked fine.

      Thanks again for your help.


      • telecastg
        telecastg commented
        Editing a comment
        Thanks for posting your solution, this will certainly help other participants.