No announcement yet.

Upgrade not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade not working


    I tried to upgrade my version 5.8.5 to 5.9 but it is not working.

    1) via SSH i ran the command "php command.php upgrade".
    The command is executed but nothing happens. No response comes. Just nothing.

    2) I tried to download the upgrade file and upload it in the admin panel, but it will not install and throw this error message: Error 500: It's not an Installation package.

    Can you help me?

    Thank you!


  • #2
    Hi Leo,

    Did you check data/logs. Any errors there?

    Did you ever upgrade from CLI before?


    • #3
      Hi pileo,

      Here is an article I written for internal use (and future person that will be taking over from me if I disappear). Hopefully it might help you. My guess is that you are not in the right folder and the "command.php" file is not found. Either that or it a User access issue, you don't have the right to run any command. If you are missing those the command.php and upgrade.php then you are in the wrong place or a corrupted installation.

      This article give guide on how to maintenance and step and procedure in the CRM System. Information here should be written for the public audience.
      [B]How to use Upgrade or use SSH CLI[/B][LIST=1][*]Download or open a SSH or CLI software. One example is Putty.[*]Open Putty. Fill in the IP address (grab these detail from your Host/Server).[*]Fill in the SSH Port[*]Connect. In popup windows.[*]Type in your username (if it VPS it is usually root)[*]Type in your password (you can't see it being type due to security reason but whatever you type will be recognized). Press Enter after typing in. If password fail it because you type in wrong password.[*]Type in "ls" (that is an L and a S) to list the directory. Find your CRM folder. It might be in public_html.[*]Change to public_html folder by typing, "cd public_html" which mean Change Directory.[*]Type "ls" again or "cd" until you get the right folder. Where the "upgrade.php" file is located.[*]Type in the command,  "php command.php upgrade". Press enter and it will say, "Enter [Y] to continue".[*]Type in "y". Press enter.[*]Wait for the Downloading... to complete.[*]It will then go into "Upgrading..... this may take a while......."[*]Wait till it say, "Upgrade is complete."[*]After that you are upgraded.[/LIST]
      Doing a quick search here is a better article.
      I'm with Hostinger and can help you if you are as well, but SSH is quite standard so I think the Tutorials/guide it is applicable to all host, including private server.
      Last edited by espcrm; 05-20-2020, 04:30 AM.


      • #4
        Just had the same problem upgrading to 5.9.1 , I would type php command.php upgrade and nothing happened, but it turned out to be that I was in the wrong directory !, once I realized my silly mistake, everything went smoothly following espcrm instructions.