Announcement

Collapse
No announcement yet.

Upgrade 5.5.6 to 5.6.0 Error 406

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade 5.5.6 to 5.6.0 Error 406

    Hi guys,
    When I select to upload the upgrade file EspoCRM-upgrade-5.5.6-to-5.6.0 and click the button UPLOAD I receive an error message saying ERROR 406 like the image attached.

    Why this error?

    Could you help me?

    Click image for larger version

Name:	error-406.png
Views:	80
Size:	28.9 KB
ID:	47532
    Attached Files

  • #2
    Hello,
    Please attach the screenshot with a whole error statement (if it possible on English please). Check the error log files. This will help you to find them https://www.espocrm.com/documentatio...ent-check-logs. Also, try to debug the problem, press F12 in your browser, then switch to the 'network' tab, call error again, and check if there appear red records. This is an error. If you have caught some error, switch to the 'console' tab and take a look on it.

    Comment


    • #3
      Originally posted by Maximus View Post
      Hello,
      Please attach the screenshot with a whole error statement (if it possible on English please). Check the error log files. This will help you to find them https://www.espocrm.com/documentatio...ent-check-logs. Also, try to debug the problem, press F12 in your browser, then switch to the 'network' tab, call error again, and check if there appear red records. This is an error. If you have caught some error, switch to the 'console' tab and take a look on it.
      Thanks a lot Maximus.
      I went to F12 and saw the error. The image is attached, but I don`t know what to do now! lol
      Could you help me?

      Click image for larger version

Name:	error_print.png
Views:	67
Size:	11.8 KB
ID:	47567
      Attached Files

      Comment


      • #4
        Have you checked the log files?

        Comment


        • #5
          You can try to install upgrade through CLI

          by running the command

          php upgrade.php /path/to/upgrade/package.zip

          Comment


          • #6
            Originally posted by Maximus View Post
            Have you checked the log files?
            Hi Maximus
            Here is the log:

            [2019-04-05 03:18:27] Espo.ERROR: API [GET]:/:controller/action/:action, Params:Array ( [controller] => Admin [action] => uploadUpgradePackage ) , InputData: - Action GET 'uploadUpgradePackage' does not exist in controller 'Admin'. [] []
            [2019-04-05 03:18:28] Espo.ERROR: Display Error: Action GET 'uploadUpgradePackage' does not exist in controller 'Admin'., Code: 404 URL: /api/v1/Admin/action/uploadUpgradePackage [] []


            Could you help me?

            Comment


            • #7
              Hi Hamilton,
              have you tried to make upgrade via CLI as Yuri has suggested? Please try it and reply.

              Comment


              • #8
                Originally posted by Maximus View Post
                Hi Hamilton,
                have you tried to make upgrade via CLI as Yuri has suggested? Please try it and reply.
                Hi Maximus,
                Yes, I had tried make upgrade via CLI, but I received an error too.

                This is the error
                Current version is 5.5.6
                Start upgrade process...
                Error: Your PHP version does not support this installation package.

                But I have the right PHP. This is the System Requirements->PHP Settings:
                PHP Version 7.1.24 Success

                I don`t know more what to do.

                Why is it saying "uploadUpgradePackage' does not exist in controller 'Admin' "?

                Comment


                • #9
                  Ok, so now please make a screenshot of this: Administration -> System requirements. We want to see what is php version is using by your web server.

                  Comment


                  • #10
                    Originally posted by Maximus View Post
                    Ok, so now please make a screenshot of this: Administration -> System requirements. We want to see what is php version is using by your web server.
                    Screenshot is attached.

                    Click image for larger version

Name:	SystemRequirements.png
Views:	75
Size:	61.5 KB
ID:	47971

                    Comment


                    • #11
                      1. When you have tried to upgrade EspoCRM via UI it caused the server Error 406. This error could be generated by the mod_security module. Mod_security, a type of firewall program that runs on Apache web server, scans for violations of the rules it has set. If an action occurs that violates one of these rules, the server will throw a 406 error.
                      So check please Mod-security, or if you are not the server owner please contact with support service.
                      2. When you have tried to upgrade EspoCRM via CLI it caused the Error: Your PHP version does not support this installation package. This error generated because your CLI PHP version is to low. It should be >= 7.1. To check it please input in your terminal the next command:
                      php -v

                      Comment

                      Working...
                      X