No announcement yet.

Ajax failed

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ajax failed


    I try to install Espo CRM and get on the Error "Ajax failed". What is the reason for this fault?


  • #2
    Sounds like a server configuration issue. Can you post here info about your server?

    I am using Ubuntu 12.04, PHP 5.5.8, Apache 2.4.6 + mod rewrite enabled.

    Also change the owner for Espo CRM instance to www-data and make data folder writable. I had some issues with the folder owner, maybe that helps.


    • Guest's Avatar
      Guest commented
      Editing a comment
      Try PHP 5.4 it might work. We had a working version of this CRM and when we upgraded our PHP last week it stop working. As im not tech guy i bring back my PHP version from 5.5xx to 5.4 and now its working fine.

  • #3

    Thank you for your response. I fixed it an the systems works now.



    • #4
      Hi Andi

      I have the same problem. Can you tell me how you fixed it in your case?




      • #5
        Hi Charles,

        It can be a server configuration issue or file permission. Please check the permission, it should be 755 for folders and 644 for files.


        • #6

          I am trying to install espoCRM but I follow all the steps and at the end of the top bar does not finish loading and does not show me no type of error.

          What will be the problem?


          • #7

            Please check the log file. It locates at data/logs.


            • #8
              hi all,
              i have same problem at installation with error "ajax failed"
              and logs in data :
              [2014-06-23 21:47:31] Espo.ERROR: Json::decode(): [] []

              what this problem ?


              • #9
                Hi danangindrak,

                It can be related with the server configuration.
                Does your server support JSON
                Please check if espo has the following permission: 755 (directories) and 644 (files), "data" and "custom" - 775 and 664 respectively.Also, all files should be owned and group-owned by the webserver process.


                • #10
                  I'm trying to install on Windows and also on Linux machine, but always get Ajax failed error message.
                  In Linux, right in the Database configuration screen, in Windows the message appears in the Administrator Setup screen.
                  I've already tried the solutions/workarounds mentioned above, including file and folder permissions.
                  Can you help, please?

                  PS: I'm using version 2.2.0

                  PPS: I've tried installing version 2.1.0 and I'm getting the same error.
                  Last edited by bugFree; 08-06-2014, 12:16 PM.


                  • #11
                    Hello. I have the same problem.
                    First problen in not instal mani tables. In log "Syntax error or access violation: 1101 BLOB/TEXT column 'description' can't have a default value'"
                    I fixed it with the comment string field "default" in application/Espo/Core/Utils/Database/DBAL/Schema/Column.php

                    Second problem
                    api/v1/Metadata 401 (Unauthorized) and Ajax Failed
                    Not add user in DB after table install

                    I'm using ver. 2.1.0 and 2.2.0


                    • #12

                      I'd like to help you but I don't know what the reason of these errors. The guy who made installer and responsible for server configuration issues will be back from his vacation soon and will look.

                      I believe this is a file permissions issue. index.php and api/v1/index.php should be executable. Also Web.config and rewrite rules should be enabled on the windows server.


                      • #13
                        Thanks for the answer. Right okay, I checked. 401 error issues is espo, I commented code, another message is displayed and everything was ok, but when the code works espo, it gives 401.
                        When can a guy that worked installer?

                        Sorry for bad English, it's translator))


                        • #14
                          Any update on this issue? I also cannot install it on my server. I tried migrating my local XAMPP install to the server, but I am getting 500 errors. I have been using Sugar since version 4.5 ... I really like Espo and want to ditch Sugar as soon as possible

                          UPDATE: Just tried installing EspoCRM-2.3.0 with the same result
                          Last edited by BOC; 08-13-2014, 07:01 AM.


                          • #15
                            It can be different causes. BOC, please send me access details via PM, and I'll try to figure out.