Announcement

Collapse
No announcement yet.

Service 'App' was not found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Service 'App' was not found

    Hi,

    after Update 4.8.4 to 5.0.5 I always get the error "Fehler 500: Service 'App' was not found".
    Even after clearing cache, restarts...
    I tried installation now 3 times from running system 4.8.4, always the same error. Are there any hints?

  • #2
    Hi,
    try to set the permission again.
    https://github.com/espocrm/documenta...lation-process
    Job Offers and Requests

    Find Developer
    Find Customer

    Comment


    • #3
      Hi tanya,

      thanks for the quick response.
      Setting the permissions does not help at all. Even if I set read/write or admin permissions to the whole folder and all sub folders it remains the same error. Any other hints? I could try stepwise update but I only can find the updatefile for 4.8.4 directly to 5.0.5.

      Comment


      • #4
        Hi,

        I can suggest checking whether the file application/Espo/Services/App.php exists. Check its prermissions and owner.

        Comment


        • #5
          Hi Dr. Sebastian,
          we found one crashed file in update. Could you replace the content in file /application/Espo/Resources/metadata/entityDefs/Template.json with this https://github.com/espocrm/espocrm/b.../Template.json
          Rebuild EspoCRM (if you couldn't do it with UI, you can run rebuild.php in terminal)
          Try now. And also check espocrm log (data/logs)
          Job Offers and Requests

          Find Developer
          Find Customer

          Comment


          • #6
            Hi,

            sorry for the delay but I can only test this once per week on our real system while it is not used.
            application/Espo/Services/App.php - does not exist after update.
            Replacing the Template.json also does not help at all.
            I get still the same error and a big log after update! No error with Version 4.8.4 in the logs.
            The log is to big to upload here so I only uploaded the last lines.
            I really hope we find a solution!
            Attached Files

            Comment


            • #7
              On my current installation 4.8.4 there also is no:
              "application/Espo/Services/App.php"
              And also no "
              /api/v1/App/user" directory
              Last edited by Dr. Sebastian Ebert; 02-22-2018, 06:07 AM.

              Comment


              • #8
                This service was add in 5th version.
                Could you try to run upgrade with current (updated) upgrade package? Set before correct permission.
                You can create a test version for this process
                Job Offers and Requests

                Find Developer
                Find Customer

                Comment


                • #9
                  Thank you very much for your fast response!
                  The last Upload for the upgrade package 4.8.4 -> 5.0.5 was from 2018.02.16. So I already used the lastest version as I downloaded it this morning from https://www.espocrm.com/download/upgrades/
                  The result was as I posted. I can't find a newer upload!
                  But I found your upload on sourceforge where the stepwise updatefiles from 4.8.4 -> 5.0.0 and ongoing are still available.
                  I'll give this a try next week as I'm not in my office at the moment. I'll give you a report if it works. By now I believe that some files are missing in the big update-file from 4.8.4->5.0.5. Hope stepwise update will help.

                  Comment


                  • #10
                    Hi, now i've tried all your updates files.
                    EspoCRM-upgrade-4.8.4-to-5.0.5 leads to the error described above.

                    stepwise update doesn't update:
                    EspoCRM-upgrade-4.8.4-to-5.0.0 finishes with no errors listed in the "report" on the update screen but "Error: 500" pops up directly after the update. After clearing cache and refreshing it still tells me I've version 4.8.4 installed?!

                    Edit: I've also tried those updates with global read/write and admin rights...

                    Is there any possibility to perform a manual update? I realy want to avoid a new installation. We've spend lots of days fitting the system to our requirements with the internal entity editor...
                    Last edited by Dr. Sebastian Ebert; 03-08-2018, 07:02 AM.

                    Comment


                    • #11
                      Could you check apache error log?
                      https://www.espocrm.com/documentatio...pgrade-via-cli
                      Job Offers and Requests

                      Find Developer
                      Find Customer

                      Comment


                      • #12
                        At least we managed to find the failure. It was the PHP max_execution_time 240 was not enough for this update! Wouldn't it make sense to show such timout failures to the user instead of "error:null".

                        Comment

                        Working...
                        X