Announcement

Collapse
No announcement yet.

Error 403: permission denied after clean install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 403: permission denied after clean install

    I'm just starting with ESPO CRM. Install went perfect, but when trying to edit UI settings as an admin, I'm getting consistent Error 403: permission denied.

    Using firebug, I can see this happens when connecting to the API:
    <HTML><HEAD>
    <TITLE>403 Forbidden</TITLE>
    </HEAD><BODY>
    <H1>Forbidden</H1>
    You don't have permission to access /espo/api/v1/Settings on this server.
    <HR>

    </BODY></HTML>

    I've checked directory permissions and api-htaccess, this all seems fine...

    Thanks for your support. Espo CRM looks really promising, it would be a pity to be stuck on this issue.

    Kind Regards,
    Oscar

  • #2
    Hello,
    recheck permission and owner to the folder 'data'
    check log file

    Comment


    • #3
      Without success. What log file are you referring to?

      Thanks for your assistance!

      Comment


      • #4
        espocrm log
        data/logs/

        Comment


        • #5
          No log-file of today is generated...

          My apache log shows:
          [Mon Oct 31 13:09:10.150329 2016] [access_compat:error] [pid 14234] [client 193.53.101.8:40866] AH01797: client denied by server configuration: /home/uagito/domains/agito-labs.be/public_html/espo/api/v1/Settings, referer: http://www.agito-labs.be/espo/ My guess is there's something wrong with the htaccess in the api/v1 folder:
          RewriteEngine On

          # Some hosts may require you to use the `RewriteBase` directive.
          # If you need to use the `RewriteBase` directive, it should be the
          # absolute physical path to the directory that contains this htaccess file.
          #
          RewriteBase /espo/api/v1/

          RewriteRule .* - [E=HTTP_ESPO_CGI_AUTH:%{HTTP:Authorization}]

          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteRule ^ index.php [QSA,L]

          Comment


          • #6
            try to check the server configuration
            https://www.espocrm.com/blog/apache-...n-for-espocrm/

            and also check if PATCH request is enabled
            http://stackoverflow.com/questions/2...-403-forbidden
            Last edited by tanya; 10-31-2016, 02:14 PM.

            Comment


            • #7
              I've changed the htaccess in the root folder, by adding:
              <ifModule mod_headers.c>
              Header always set Access-Control-Allow-Methods "POST, GET, PUT, PATCH, DELETE"
              </ifModule>
              on top and

              <Limit GET POST PUT DELETE HEAD OPTIONS PATCH>
              Order allow,deny
              Allow from all
              </Limit>
              on the bottom.

              This resolved the issue!

              Thanks for the support

              Comment


              • #8
                where have you add that codes?

                Comment


                • #9
                  Originally posted by odparada View Post
                  where have you add that codes?
                  httpd.conf in conf apache directory...use vi httpd.conf to edit, and put at the top

                  <ifModule mod_headers.c>
                  Header always set Access-Control-Allow-Methods "POST, GET, PUT, PATCH, DELETE"
                  </ifModule>

                  at the bottom

                  <Limit GET POST PUT DELETE HEAD OPTIONS PATCH>
                  Order allow,deny
                  Allow from all
                  </Limit>

                  then save and restart apache...

                  works

                  Comment


                  • #10
                    Hello, got the same issue with my clean install. No modifications recorded, saving loop. I'm a first time user...
                    I tried the solutions above but still no luck

                    So I asked my webhosting.
                    They said that the only http verbs supported by them are GET|HEAD|OPTIONS|POST|PUT|DELETE .
                    PATCH is not proposed and will not answer (444)

                    Do you know if there is a workaround to make it work or if it is completly blocked ?
                    Thank you

                    Comment

                    Working...
                    X