Announcement

Collapse
No announcement yet.

Entering Number in filed 'phoneNumber' creates Error 400

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • agri
    replied
    I tried this and that, and things work now. I'm sorry, I cannot say precicely what has solved the problem ...
    Again thank you for your help!

    Leave a comment:


  • agri
    replied
    Originally posted by yuri View Post
    I didn't know that you have a custom regular expression. Such details needs to be provided initially.

    There was no any change in v7.2.7.
    Sorry, I didn't think of that, as you answered my post concerning a custom regex.
    Thank you so far, I will investigate and see, what I can find ...

    Leave a comment:


  • yuri
    replied
    Did you try to save other type than "Buro"?

    Please consider debugging the class Item referred, I don't have time for the forum.

    Leave a comment:


  • yuri
    replied
    I didn't know that you have a custom regular expression. Such details needs to be provided initially.

    There was no any change in v7.2.7.

    Leave a comment:


  • agri
    replied
    Originally posted by yuri View Post
    Type is phone type. What phone type value you tried to save.
    Well, just what you would type in into a phone number field. Such as just numbers or an combination like "+49 (0) 1234/6789". Should be no problem, referring to "phoneNumberLoose" in \var\www\html\custom\Espo\Custom\Resources\metadat a\app\regExpPatterns.json
    Click image for larger version

Name:	grafik.png
Views:	273
Size:	29.0 KB
ID:	85868
    I must appologize, if I didn't get you right!​

    Leave a comment:


  • yuri
    replied
    Type is phone type. What phone type value you tried to save.

    Leave a comment:


  • agri
    replied
    Fieldtype? Field "phoneNumber" is of type "Telefon". Hm, even if in preferences I set language to english, it says "Telefon". Should be "PhoneNumber" ...
    Last edited by agri; 12-02-2022, 03:40 PM.

    Leave a comment:


  • yuri
    replied
    What type.

    Leave a comment:


  • agri
    replied
    e.g.:
    123
    +49 (0)841/9323457
    084316478

    Leave a comment:


  • yuri
    replied
    What value you are saving?

    Leave a comment:


  • agri
    replied
    I changed setting to this:

    Click image for larger version

Name:	grafik.png
Views:	297
Size:	26.1 KB
ID:	85858
    Save, clear cache, rebuild. Still it does not work - error as before.

    Leave a comment:


  • yuri
    replied
    It's because you had the Büro (not translation) option before and removed it after. But it did not remove it from the Default Value (the bug we had before). So now you had Office as a valid value, but Büro as a default value (not valid value).

    You won't loose any data if you run an SQL query updating Büro => Office.
    Last edited by yuri; 12-02-2022, 03:18 PM.

    Leave a comment:


  • agri
    replied
    Originally posted by yuri View Post
    Change the Default Value (Standardtyp) to "Office" and then Save.

    Thing is that you have the default value set to "Buro" that is not a valid option. It's a translation.

    I also recommend to update all values in the phone_number table from Buro to Office.
    Translation: OMG, will I ever get it right? Thanks for the hint!
    Change type "Büro" to "Office": It's because of the Umlauts? I will have to delete my "Büro" types then and set new "Office" ones. I will loose data, won't I?

    Leave a comment:


  • yuri
    replied
    Change the Default Value (Standardtyp) to "Office" and then Save.

    Thing is that you have the default value set to "Buro" that is not a valid option. It's a translation.

    I also recommend to update all values in the phone_number table from Buro to Office.
    Last edited by yuri; 12-02-2022, 02:19 PM.

    Leave a comment:


  • agri
    replied
    Hi yuri,
    looks like this (seems, there is a space in front of "Büro" in the first line of typelist -> problem?):
    Click image for larger version

Name:	grafik.png
Views:	305
Size:	34.9 KB
ID:	85850

    Leave a comment:

Working...
X