Announcement

Collapse
No announcement yet.

Workflows are not being triggered

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Jakub Grufik,

    1. Do you have any unofficial extensions or code customizations?
    2. Have you tried putting a new instance on your server, do workflows work there?

    I recommend contacting EspoCRM technical support. Most likely, there will be a need to access your instance and/or server.

    Comment


    • Jakub Grufik
      Jakub Grufik commented
      Editing a comment
      hello mate, we already fixed the issue with the CEO, I will prepare the report what happened and how we fixed it. Thanks a lot!

  • #32
    Jakub Grufik,

    Incredibly happy to hear! We look forward to a description of the problem and, of course, a description of its solution.

    Comment


    • #33
      Hello everyone,

      Yesterday I managed to work on this issue with Jakub Grufik using TeamViewer, it took about one hour, and I would like to share the feedback here.

      First of all, this is not the first time I face this problem, and every time I fix it, I go over multiple steps and some steps repeated more than one time till it fixed.

      I think this is related to the size of table job in most cases, on the case here we found more than 4 million record and that is too much for some servers, I suggest the following points to manage this:
      • Check the size of table named "job", will be safe to remove all records with status != pending and date is older than one week, you can use this sql statement:
        DELETE * FROM `job` WHERE status <> 'Pending' AND date(execute_time) < '2022-11-28';
      • I think it is good choice to change the cleanup time cleanup params like cleanupJobPeriod
      • I suggest to change the value on clean up job from 1 1 * * 0 TO 1 1 * * *‚Äč
        Click image for larger version  Name:	Screenshot 2022-11-30 at 2.36.28 PM.png Views:	0 Size:	35.0 KB ID:	85770
      remove the job and re add it again then rebuild, if you have lot of personal or group email account I suggest to increase the server parameters or just make the job that fetching email more slower, every 2 minutes is good maybe.

      Sorry for the maybe bad explanation because of writing quickly, hope I have the time later to make an article about this topic that cover some other points about crm management.
      Software Engineering, working with Espocrm since 2014
      CEO @ Eblasoft Ltd.
      Contact Me

      Comment


      • #34
        eymen-elkum hello man,

        thank you a lot for the summarization of the issue and solution. I am currently very busy at work trying to clean up all the data affected by the outage of workflows so I was going to make this summary at the end of this week.

        I will keep checking this and I will also put together some report with information on what happened and how we resolved it from my point of view at the end of this week.

        Last but not least, a huge THANK YOU goes to the whole team and to all of YOU guys who were trying to help me with this issue. It is always a pleasure to cooperate with such experienced and helpful people like you.

        If there will be ANYTHING I could help you with do not hesitate to reach me here or by email at grufik.k@gmail.com

        Great job guys! Thank you!
        Have a nice rest of the day

        Comment


        • rabii
          rabii commented
          Editing a comment
          Glad you sort it out now. i think it would better to let the development know about this so they could investigate their end why such issue happened and if they could provide a fix in future upgrade of advanced pack.
          Thanks

      • #35
        I had this issue last month and thought it was my server because I couldn't find a solution so I changed my entire server. Im kinda worried the issue may show its face again. So a good solution is always welcome'd

        Comment

        Working...
        X