No announcement yet.

Setting access for reports

  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting access for reports

    Hello, I have created report for our regular users. However, I am not able to crack the access

    Whenever they try to show the report they got error 403: access denied.

    Could someone please tell me what exactly I need to set up in roles for the regular users so that they will be able to see my report?

    - report contains User data
    - user is part of team "Vedenie" which is the team assigned to the report
    - report assigned user is empty
    - user has access to reports in "Scope level"
    - I guess I need to set up something in "Field level"??? (for example, if the report contains the user's data do I have to allow it somehow in Field level -> user?)

    Sorry if the question is too stupid but I was not able to find any information in docs about setting the access to reports etc.
    Thanks a lot for the help!

    Click image for larger version

Name:	reportaccess.jpg
Views:	352
Size:	74.0 KB
ID:	83074Click image for larger version

Name:	reportaccess2.jpg
Views:	317
Size:	55.4 KB
ID:	83075Click image for larger version

Name:	reportaccess3.jpg
Views:	286
Size:	61.9 KB
ID:	83076

  • #2
    Any help please?

    I still was not able to make it work and I need to set up reports for my boss. He is still getting an Access denied error.

    Thanks in advance!


    • #3
      Hi Jakub Grufik,

      The fact is that in order to give access to Reports, you must first give access to a specific Entity to a specific role. This role should belong to a specific team (screenshot 3), and we will assign this team to our Report.
      Just giving access to some report is not enough, because the report is built on the basis of data from Entity records. If there is no access to the Entity, then there is no access to the report on this Entity.

      That is, you need to give User access to the Entity (1 screenshot)> then assign the role of your user to the team (which is set in advance in the report screenshot 2) > give the user access to the Entity "Reports" screenshot 1 again.​
      Attached Files
      Last edited by victor; 09-19-2022, 10:01 AM.


      • #4
        Hello victor, firstly I would like to thank you for your effort and help!

        I am trying to follow your steps. Unfortunately, it is still not working even though the settings are exactly the same as you suggested.

        Could you please try to look at my screens and check if you notice some incorrect settings?

        Also, do you know why assigning a specific role to the user is not enough for him to be able to see the report? Why there are 2 extra steps needed?(assign role to the team, assign the team to the report) - I am just curious if this is expected behavior.

        Again, thank you very much for your time.

        ps. Could you please tell me which snipping tool you use for blurring part of the image? Thanks
        Attached Files


        • #5
          It seems that access to 2 team simultaneously limits the rights of this user. Try to give him only 1 team with rights to view reports and users. You can check my hypothesis and the absolute rights of a specific user in Users -> Your user name -> Access (screenshot 1).

          (assign role to the team, assign the team to the report)

          Can be directly assigned to a specific user to report. But this user must have a role that has access to both Users and Reports.

          ps. Could you please tell me which snipping tool you use for blurring part of the image? Thanks
          I use Screenpic 0.15.2 (screenshot 2).
          Attached Files
          Last edited by victor; 09-19-2022, 11:26 AM.


          • #6
            Thanks a lot for the help and tips, will try and will update this topic on how it ended up )


            • #7
              Unfortunately, I am still getting 403: Access denied Even when the access seems to be set up correctly (screen1)

              I am clueless about what to do to make it work.

              edit: I tried to set User permission to "All" but its not working either
              edit2: we are using
              Advanced Pack 2.11.4
              Attached Files
              Last edited by Jakub Grufik; 09-19-2022, 11:52 AM.


              • #8
                Please anyone that could help me with setting up access to the report? I am just not able to find a working solution.


                • #9
                  Hi Jakub Grufik,

                  We will do our best to help you as quickly as possible, don't worry.

                  Please tell me, do the fields you select in the columns of your Report have a relationship with other entities? With Leads, for example? Where do their values come from? Are they filled in manually in the User's record or are they fields of the Foreign or Link/Link Multiple type?

                  Could you show the Field Level in user's Access in the User part? What fields does he have access to?

                  Also, could you send error logs? They are located in [your_instance_folder]/data/logs folder.

                  I shall be very grateful to you for the answer.​
                  Last edited by lazovic; 09-20-2022, 09:52 AM.


                  • #10
                    Hello lazovic thanks a lot for your time and help.

                    The fields used in the report are User´s attributes and they have been created manually with the default value of 0 and are being filled/adjusted by workflows.

                    As far as I know, there are no relationships set manually.

                    For example, we have a workflow that is checking Lead after creation and is updating related record "Assigned user" (basically adding 1 to the user´s field "numberOfLeads", field "numberOfLeads" is then being used in the report we are talking about).

                    Field Level in user´s access is set to default, which should be "access to everything" according to this information in espo docs "By default, user can read all fields if one can read the record." (screen1)

                    About the error log, I am going to send an email to our implementation specialist/developer who is taking care of our Espo backend (will update as soon as I have it).

                    Hope everything is clear and I am giving you the information you are looking for!
                    Thanks a lot one more time, I appreciate it.
                    Attached Files


                    • #11
                      Jakub Grufik,

                      You are welcome!

                      Thank you for your answer. I will wait for the error log, but I will also try to recreate your situation.

                      Tell me, please, have you tried to go from the opposite? What I mean: try to duplicate this Report and edit the duplicate first so that only Users are displayed (without columns, grouping and order). Will they show up at all?
                      If yes, then carefully try to insert one column at a time, save and see if the error reappears.

                      I hope you understand what I mean. This may be a little time consuming, but in this case we can understand where the error comes from.​


                      • #12
                        lazovic I tried to break it as much as I could but without success. BUT, I think I finally got it now! I am so sorry that I have not tried to break it, even more, to be able to figure it out on my own. The filters are what is making the report inaccessible. (screen1) Could you please tell me what needs to be enabled in Roles to make it work?

                        edit: I tried to enable User.Roles, in Field Level but nothing has changed
                        Attached Files
                        Last edited by Jakub Grufik; 09-20-2022, 11:18 AM.


                        • #13
                          Jakub Grufik,

                          I have some doubts about the fact that Roles are generally available for viewing/analysis by Regular Users even in Reports.

                          At the moment I suggest you filter the results of Report by Teams.


                          • #14
                            Wow man lazovic that is exactly it!

                            Finally, the report is working even for regular users! We did it man! Thanks a thousand times for your time and for the workaround you suggested (filtering by teams instead of roles) it is now working as expected!

                            I am afraid that without an experienced espo user like you I would not be able to figure it out because it was such a rare situation.


                            • lazovic
                              lazovic commented
                              Editing a comment
                              You are welcome. I was extremely happy to help you.
                              And I believe that over time you will become an experienced EspoCRM user and will be able to help other members of our community in the same way.