No announcement yet.

Can only edit text field using inline edit (pencil).

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can only edit text field using inline edit (pencil).

    We have a custom "text" field that will no longer allow editing using the main "Edit" button, but instead can only be edited using the inline edit feature (clicking the pencil).

    This is a custom "text" field that was added to the contacts entity. It previously worked so that a user could edit either by clicking the main "Edit" button or by using inline edit.

    Recently, its behavior changed so that users can only edit via clicking the pencil (inline edit). I can't think of anything that we changed that would have had this effect, and can't find a way to change it back.

    The custom text field is called "nextSteps". Here is the settings entry for that field in the Contact.json file (.../Custom/Resources/metadata/entityDefs/Contact.json).

    "nextSteps": {
    "type": "text",
    "required": false,
    "rows": 30,
    "lengthOfCut": 255,
    "maxLength": null,
    "seeMoreDisabled": false,
    "readOnly": false,
    "tooltip": false,
    "isCustom": true

    Here is the settings entry for the field in the .../clientDefs/Contact.json file under the "dynamicLogic" section.

    "nextSteps": {
    "visible": null,
    "readOnly": null

    I can't find any settings that will fix this. Any ideas would be appreciated.

  • #2
    Hi there,
    Try to open this window in the incognito mode. If the issue won't reproduce, then clear a browser's cache within its advanced settings.


    • #3
      Thanks. I tried that on a couple of different browsers; cleared the browser cache and tried using an incognito/inprivate window. Same results. I tried it on another computer/browser combination. Still the same results.

      I just rebuilt and cleared the EspoCRM backend cache from the admin panel and re-tried. The issue still persists.

      I love EspoCRM. But I'm stumped on this issue.


      • #4
        Maybe you can delete the field and create it again with the same type and same name? I believe that will "forget" about any custom setting you have with it. Do try it in a test environment first though.


        • #5
          Found the problem. The text field that was problematic was displayed both in the main detail view and also in a side panel. The entity layout let me put this text field both in the "detail" view and in a "side panel" view. I'm not sure if this is a bug, or just something that I shouldn't have been doing in the first place.

          But I found that as long as the entity layout has the field displayed only once, the edit and inline edit features work as intended.



          • espcrm
            espcrm commented
            Editing a comment
            You can report it that as a bug and see.