No announcement yet.

Print to PDF not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Print to PDF not working

    Hi, I tried the print to pdf templates. But When I click on the button, and then choose the template, I just have a new tab that opens, with a white content. The printing popup does not show up, nor the chrome pdf viewer.

    Are there tweaks to make to the permissions or something? Is the pdf stored in a temp location on the server?

  • #2
    Maybe there is something wrong in your template code. I see a white browser tab, when there is an error in my code. This already happened to me.
    If the code is correct in chrome there opens a new tab with the usual pdf viewer.


    • #3
      Just tried creating a new Entity (from Base), and added one record. Created a template with {{now}} in header and {{name}} in body. And it is still not working.
      I am using latest espocrm version, with just one modification to have resizable columns (see corresponding post on this forum).

      I tried on one of my test instances using v5.6.8, and the PDF template works fine.

      So I am thinking that either the latest version introduced a bug, or my custom code (but I really don't see why, since it is not about the same page type). Or maybe all the folders don't have the same permissions... Would there be a specific folder to check?


      • #4
        When using mass update to do it, I get a "Bad Server Response"


        • #5
          You have to check your Logs. Check the file:

          Assuming no template error; I have a feeling that your PHP pdf-engine might be disabled or it not installed properly.

          Did you do a simple Print-to-PDF? such as just writing something like "test"