Announcement

Collapse
No announcement yet.

Event Subprocess execution

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Event Subprocess execution

    Hello.

    I'm running the BPM process you see in the attached image.

    That process has two event sub-processes defined.

    One is activated by signal and the other by error.

    During the execution of the process the flow does not go through either signal activation or error activation.

    However, as shown in the figure, both event subprocesses are activated.

    in the case of the error sub-process:
    - has no error code defined.
    - the subprocess has been executed
    - the mail is received by the defined user (It is a confirmation that the sub-process is actually executed)

    in the case of the signal sub-process
    - no code has been defined either
    - the sub-process is running
    - a task assigned to the defined user is not generated.

    If the flow does not go through the error activation, how can I prevent the error sub-process from being executed?

    Thank you very much.


  • #2
    Hi,

    Any errors in data/log? If there's no error code defined I believe that any thrown exception can cause the error node be triggered.

    Signal can be broadcasted by another process. BTW signals nodes are not supposed to be w/o defined signal name.
    Last edited by yurikuzn; 05-21-2020, 01:42 PM.

    Comment


    • #3
      Hi,

      Yes. There was a message in the data log.

      [2020-05-21 12:25:20] Espo.WARNING: BPM: No signal for sub-process start event [] []

      The timestamp corresponds to the execution time of the BPM process.

      So, if I undestood properly:
      I should include a signal name, This should avoid the error in the data log
      And once this is done, the error subprocess should not be triggered

      Going to test that and let you know

      Thankyou

      Comment


      • #4
        I tried to create a similar flowchart w/o error code and signal name defined. After running, Sub-Process Signal Start Event was marked as failed (in the log panel). And there was no issues like in your case. Maybe you have an older version.

        Comment


        • #5
          Hi.

          Might be I'm in an older version, I'm currently running 5.8.5. Not so old. I will upgrade to the last soon.

          I have included a signal name and now the error included in the log has dissapeared.

          Nevertheless, for testing reasons I hace done a simpler version of the flowchart. Just to test the error and signal behaviour. Is working flawless.

          So, there is something different from the simpler version to the complete version of the flowchart. It should be the logic or coding of it.

          You said arlier: "If there's no error code defined I believe that any thrown exception can cause the error node be triggered."

          Just guessing: Could be somekind of error in the details of the flowchart code?

          It shouldn't be important enough to be recorded in the log, as there is nothing into it. But relevant enough to trigger the error subproccess.

          Does that make sense to you? If so, what kind of things would you be looking for in my code?

          Thanks in advance

          Comment


          • #6
            I've been running several tests and I've come to conclusions

            I have tested the process that activates the error and signal without cause in two ways.

            1.- As it was originally designed: it is a call activity of a larger process. Executed this way, the described error is generated.
            In this case it does not matter if I put a name to the signal. The signal sub-process is still activated

            2.- as a standalone process. It becomes the main process and runs smoothly: neither the error call nor the signal sub-process are activated.

            I thought that the cause of the problem could be the last task of the sub-process: an update of a related record. I took it out of the sub-process and put it into the main process.

            It was of no use: the sub-process kept giving the same error.

            i have concluded that you cannot put error calls or signal sub-processes into a call activity.

            What I don't know is if this is a bug or was designed that way from the beginning.

            Thanks in advance

            Comment


            • #7
              I fixed this problem in 2.5.12.

              Comment


              • #8
                Thanks!!

                Comment

                Working...
                X