No announcement yet.

Bad Server Response when converting a Lead

  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad Server Response when converting a Lead

    When I try to convert a lead, I get an error. I've done some mild configuration on the Contact entity (just a few custom fields). I believe the others are out of the box. I tried a few different variations of conversion (contact only, contact + opportunity, etc...) No matter what, I get an error.

    I checked the log and this is the message I get:

    [2020-05-14 04:45:24] Espo.ERROR: Uncaught Exception TypeError: "Argument 2 passed to Espo\Modules\Crm\Services\Lead::convert() must be an instance of Espo\Modules\Crm\Services\object, instance of stdClass given, called in /home3/alldone/public_html/crm/application/Espo/Modules/Crm/Controllers/Lead.php on line 50" at /home3/alldone/public_html/crm/application/Espo/Modules/Crm/Services/Lead.php line 186 {"exception":"[object] (TypeError(code: 0): Argument 2 passed to Espo\\Modules\\Crm\\Services\\Lead::convert() must be an instance of Espo\\Modules\\Crm\\Services\\object, instance of stdClass given, called in /home3/alldone/public_html/crm/application/Espo/Modules/Crm/Controllers/Lead.php on line 50 at /home3/alldone/public_html/crm/application/Espo/Modules/Crm/Services/Lead.php:186)"} []

    Any help would be very much appreciated!

  • #2
    Do you have custom codes? seems you wrongly passed the entity to the function somewhere.
    CEO of Eblasoft
    EspoCRM Expert since 2014
    Full Stack Web Developer since 2008
    Creator of Numerous Successful Extensions & Projects​


    • #3
      I don't have any custom code. I should have mentioned that in my original post.

      Also if it helps, I'm on version 5.8.2 (I'm having trouble upgrading but that's another issue) and the version of PHP is 7.1.


      • eymen-elkum
        eymen-elkum commented
        Editing a comment
        This seems needs closer look, cannot figure out the problem,

    • #4
      have you tried with only opportunity ??


      • #5
        I think I did before posting, but just to be sure I just tried again with only Account, only Contact and only Opportunity. I received the same error message in all scenarios.