No announcement yet.

BPM will not run

  • Filter
  • Time
  • Show
Clear All
new posts

  • BPM will not run

    Hi I have 2 BPMs on the Opportunity entity. One fires every time and one only fires when the stage has a certain value (using "a Conditional Start Event").

    I am sure that this used to work, but now it doesn't.

    When I look at the "Processes" for each "Process Flowchart" I can see that one has run and one has not. The one that runes every time is very simple and works, The one with the "Conditional Start Event" is not running.

    I tried to launch the one with the "Conditional Start Event" using the "Start Process" on the Opportunity page; this triggered a "400 Bad Response" error. I don't know if this is why it is not running in the first place or because you cannot launch something with a "Conditional Start Event" from the "Start Process" menu item.

    Help appreciated.


    PS - I am on the SaaS system so don't have any access to hidden logs.

  • #2
    check please a log file in the data/logs directory. Provide the detailed screenshots of this BPM.


    • #3
      Hi Maximus I am on the SaaS version so don't have access to the underlying logs.

      The BPM is massive, but as it refuses to start I am guessing that it is the start that is of interest. It does not even register as having started with I look a the Process Definition.

      I have now added a manual start to get tit going (which was not there before, neither was the merge stage), but it now looks like this:
      Click image for larger version

Name:	Snip1.png
Views:	118
Size:	22.2 KB
ID:	58273

      Here is what the un-modified process looked like for an old record where it actually ran:
      Click image for larger version

Name:	Snip2.png
Views:	84
Size:	26.7 KB
ID:	58274


      • #4
        If you click F12 you should see the error message.


        • #5
          Seems it is a bug. A field not appearing on the form. You can try to start from Processes list view. It should work. I will look into.


          • #6
            Hi Yuri, I am confused ... This used to work but has stopped. I have managed to get it working using the new "Manual Start" and launching it from the Opportunity manually, but this has worked for several weeks and I don't believe I have changed anything in that area.

            Have you seen something in the log files that let's you know what it happening?



            • #7
              I checked. It was not supposed to be able to start processes w/o regular Start Event before. I added this ability later but not changed in UI.


              • #8
                Were you able to manual start non regular start events?


                • #9
                  I have many BPMs that are only ever run based on a record update of some form. I only ever run them manually when something is broken and I need to run one of my "Fix Up" BPMs.

                  So yes I have worked around this specific issue in this instance but I would like it to work in the future.

                  Many of my processes start with a "Conditional Start Event" like this:
                  Click image for larger version

Name:	Snip3.png
Views:	94
Size:	16.8 KB
ID:	58284
                  And are never run manually. I use these in place of the old "Workflows".


                  • #10
                    Hi yuri can I get your thoughts on this please. This BPM is still not starting automatically so I keep having to start it by hand. I have loads of other BPS that start without fail every time a record is updated so I cam not sure why this one fails. It used to work.

                    Help appreciated.



                    • #11
                      Hi. I don't know. The same process flowchart worked for me. Could be that there's another active process with the same flowchart and for the same record.

                      Try to create simplified flowchart from scratch and see whether it works.


                      • #12
                        Ok, I have a work-around. I disabled the original BPM, then duplicated it and enabled the duplicated it. The new, duplicated item works a treat.

                        Guessing that there is some form of corruption in the original item.

                        Will keep you posted if I get any more info.


                        • #13
                          Hi yuri this has happened again to another BPM. The BPM had 4 potential start points and used to work fine. I made some changes and now only 3 of those start points work.

                          I duplicated the BPM (as above) in the hope that this would fix it, but now only 2 of the start points work. I duplicated it again, and still the same 2 start points work.

                          This is now more than a one off. Can someone investigate please? I am happy to share the BPM as a CSV if you want or let you log into my instance on the ESPO Cloud. The actual flow looks like this:
                          Click image for larger version

Name:	Opportunity Flow.png
Views:	88
Size:	27.5 KB
ID:	59314

                          Points 1 and 2 always seem to fire. Point 3 is the one that started to play up, now points 3 and 4 refuse to fire.



                          • #14
                            Hi Mat,

                            For me the logic of start events looks incorrect. 3rd start event is triggered every time 2nd start event is triggered. But the process will not be instantiated if there is already a process for the same record with the same flowchart.

                            2nd event triggers the process. 3rd event is ignored because the process is already started. I have already mentioned this before.


                            • MatLudlam
                              MatLudlam commented
                              Editing a comment
                              This does work. The system starts several flows if there are several start events.

                            • yuri
                              yuri commented
                              Editing a comment
                              It's not supposed to work if one of them is active. It will, if the first one managed to finish before the second event is processed. It can happen if you don't have nodes that will switch execution to idle mode.

                            • yuri
                              yuri commented
                              Editing a comment
                              You need to spit all concurrent flows into separate flowcharts.

                          • #15
                            Hi MatLudlam,
                            Please provide the CSV you mentioned to let us investigate this issue.