No announcement yet.

Your PHP version is not supported by EspoCRM, please update to PHP 7.1.0 at least.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Your PHP version is not supported by EspoCRM, please update to PHP 7.1.0 at least.

    I get this error on PHP 7.2.5. Espo is a great product unfortunately it does not work after an update...

  • #2
    Hello Larry,
    Did you tried to upgrade via UI (Administration -> Upgrade) or CLI. Check please what PHP version do you have in:
    1. Administration -> System Requirements.
    2. Run this command in the terminal: php -v.


    • #3
      I unzipped / untarred a new installation. php -v produces
      PHP 7.3.11-1~deb10u1 (cli) (built: Oct 26 2019 14:14:18) ( NTS )
      Copyright (c) 1997-2018 The PHP Group
      Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
      with Zend OPcache v7.3.11-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies


      • #4
        Ok, but check please this: Administration -> System Requirements. For work, EspoCRM uses your web server php. It should be 7.1+.


        • #5
          On the webserver host I issued the command php -v and supplied the version information. I can't get to Administration->System Requirements because I get the version error regardless of what page I try to load from ESPOCRM. On the webserver host, "Webserver PHP" is the same as command line PHP.


          • #6
            >"Webserver PHP" is the same as command line PHP.
            I believe that the php version is not appropriate.
            If you are a webserver owner you can create in the localhost root directory a simple php file (for example index.php) with this code:
            PHP Code:
            Then open it in your browser: localhost/index.php. It will show you its php version that mounted on your web server.

            If you are using an Apache webserver, you can change the php version by running these commands in the terminal:
            1. sudo a2dismode php5.6 (php5.6 is an example, you need to input your current webserver php version);
            2. sudo a2enmode php7.3;
            3. sudo service apache2 restart.

            If you are using a NGINX webserver, you can change its php version by doing these:
            1. In the NGINX config file that mapped to the EspoCRM directory change the fastcgi_pass to the correct one. Example:
            fastcgi_pass unix:/var/run/php/php5.6-fpm.sock; 
            fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
            2. In the terminal run this command to restart NGINX: sudo service nginx restart

            If you are using a host solution then you need to contact the host support service and ask them to change the php version.


            • #7
              a2enmode is not found. The latest stable release of PHP under apache on debian is 7.0. Looks like I need to search for a CRM that does work with the latest stable release of debian.


              • #8
                Please check this I believe you can upgrade your PHP version.