No announcement yet.

EspoCRM 5.7.6 suddenly no longer accessible

  • Filter
  • Time
  • Show
Clear All
new posts

  • EspoCRM 5.7.6 suddenly no longer accessible

    Hi all,

    strange thing: since yesterday I have a new installation of version 5.7.6 (no upgrade) and everything worked fine including customizations.

    Today I was logged in as admin and started to add an additional field at "customer" I have forgotten to add (yesterday I added fields and it worked). I have been in the field type selection dialog and before adding a new field the screen becomes blank (only EspoCRM background). AT this moment no other user was logged in. I checked the database, there is no additional field created.

    This happens three hours ago. Every time when I press the refresh button or change to a valid the URL I only get a blank screen with EspoCRM background. On the home page appears the copyright at the bottom, that's all. Access to a not valid URL leads to a "not found" error.
    When I try to log in from another device or browser as admin, I still see the same blank screen. When another user tries to login he get the login screen. Wrong credentials are leading to a (correct) error. Correct credentials leads to an error "Error 503: Application is in maintenance mode".

    Additional information: the EspoCRM installation is part of a hosted website without access to the crontab. Cron jobs are disabled.

    Because I have not an usable Web-GUI at the moment I logged in via ssh and tried "php clear_cache.php" and "php rebuild.php". After a few seconds the jobs finished without error message. But unfortunately this has no effect on my issue. Has anyone an idea how to turn off the maintenance mode via CLI? In the file "data/config.php I found: 'maintenanceMode' => 'false',

    Also renaming .htaccess has no effect.

    Kind regards

  • #2
    new info:
    In the file Auth.php I commented out the line that prevents the login in maintenance mode. Then normal users could log in and the application looked OK. They only get a message, that the system is in maintenance mode. Changes on data can be made.

    Afterwards I have edited the table "user" in the database because I tried to change another user to get admin rights. When I set "is_admin" to "1" it has no effect. But as soon as I changed the "type" to "admin", the same behavior of the view as with the user "admin" was there immediately. No menu and no dashlets, only the background color and the "(C) 2019 EspoCRM" below were displayed. Change "type" from "admin" back to "regular", a refresh of the browser tab is enough to see the menu and all dashlets and other windows again. But then again I don't have admin rights and can't call the administration area.

    My main problem seems to be that if a user has the type "admin", no screen contents appear anymore. With the type "regular" the screen contents are visible.
    Last edited by ingra; 11-02-2019, 02:27 PM.


    • #3
      next: in data/config.php I changed 'maintenanceMode' => 'false', to 'maintenanceMode' => false,
      That is, I have removed the quotation marks around the value "false". So the maintenence mode seems to be switched off.

      The problem that I don't get any content displayed as admin still exists.

      So I will mark this topic as solved regarding the original issue "active maintenance mode" and open a new one regarding the empty screen when logged in as admin.
      Last edited by ingra; 11-02-2019, 03:41 PM.