Announcement

Collapse
No announcement yet.

Display of a value for account and contact

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Display of a value for account and contact

    I created the field "customer protection" under the company / account. How can I show this field on every contact?

  • #2
    Hello,
    the next step you need to add this new field in the layout of the Account entity. Go to Administration --> Layout Manager --> Accounts (tab) --> Detail. Rearrange from the right sidebox new field onto the layout and save changes. Press F5 to reload a page. More information you can get here:
    1. https://www.espocrm.com/documentatio...ayout-manager/
    2. https://www.espocrm.com/video/layout-manager/

    Comment


    • #3
      Thank you for your quick response. I have already added this field in the layout for the account. But I want to display this field as well in the contacts of on account. Like the field accountname. This field is displayed in both, the account and the contact.

      Comment


      • #4
        It is simple to make a linked field. Next step is go to the Administration --> Entity Manager --> Contacts --> add field (type: foreign). Please take a look on the attachments. After field creation finished add it to the Contact layout in the Layout manager.
        Note: it will show only data stored in the linked account field of the first account name in the list.
        Attached Files

        Comment


        • #5
          Thats the way how I always tried to do. But the problem is, that if I add the field, and type "foreign", I don't see the value "customer protection", even I have created the fiel under "accounts"

          Comment


          • #6
            Please, can you give the attachments of all your settings how you have configured this field for the Accounts entity and for the Contacts entity? Also, what is your version of Espo? It could help to reproduce.

            Comment


            • #7
              My Version is 5.2.4.
              do you need more information?

              Comment


              • #8
                I got it. This option is unavailable for multi-enum field. Make enum type instead of multi-enum.

                Comment


                • #9
                  Thank you very much, this is working. But does this mean I have to create a new field? I could not change the type in the existing field.

                  Comment


                  • #10
                    Yes, changing the type of created field is unavailable. You should create a new field with an appropriate field type.

                    Comment


                    • #11
                      Thank you for your help.

                      Comment

                      Working...
                      X