No announcement yet.

SMTP in Espo

  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP in Espo

    I think I have tried everything, so I need to hear if someone on here has had the same issues and what they did to resolve it.
    The problem is, that I can't connect to a 3rd party SMTP host and what I can conclude is that is on my server. To cement the issue, I have tried with two different mail providers. What I can't figure out though, is how to fix it. The IMAP connection works without a hitch.

    Here's some info I have been able to gather. (Everything in bold is omitted)

    EspoCRM log:
    [2018-04-22 19:29:20] Espo.WARNING: E_WARNING: stream_socket_enable_crypto(): Peer certificate CN=`' did not match expected CN=`' {"code":2,"message":"stream_socket_enable_crypto(): Peer certificate CN=`' did not match expected CN=`'","file":"/home[B]/*****/*****/*****/[/B]vendor/zendframework/zend-mail/src/Protocol/Smtp.php","line":178,"context":{"host":"admin"}} []
    [2018-04-22 19:29:20] Espo.ERROR: API [POST]:/:controller/action/:action, Params:Array (     [controller] => Email     [action] => sendTestEmail ) , InputData: {"server":"","port":587,"auth":true,"security":"TLS","username":"[B][/B]","password":null,"fromName":"*****","fromAddress":"[B][/B]","type":"emailAccount","id":"5adcdd985fc6f869e","emailAddress":"[B][/B]"} - Unable to connect via TLS [] []
    [2018-04-22 19:29:20] Espo.ERROR: Display Error: Unable to connect via TLS, Code: 500 URL: /[B]*****[/B]/api/v1/Email/action/sendTestEmail [] []
    [2018-04-22 19:29:30] Espo.ERROR: API [POST]:/:controller/action/:action, Params:Array (     [controller] => Email     [action] => sendTestEmail ) , InputData: {"server":"","port":465,"auth":true,"security":"SSL","username":"[B][/B]","password":null,"fromName":"*****","fromAddress":"[B][/B]","type":"emailAccount","id":"5adcdd985fc6f869e","emailAddress":"[B][/B]"} - Connection refused [] []
    [2018-04-22 19:29:30] Espo.ERROR: Display Error: Connection refused, Code: 500 URL: /[B]*****[/B]/api/v1/Email/action/sendTestEmail [] []
    Info from PHPInfo.php
    PHP Version 7.0.29
    allow_url_fopen On On
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
    SSL Version OpenSSL/1.0.2o
    Sockets Support enabled
    An EspoCloud instans has also been made to see if that had the same issue. It does not. If works perfectly on EspoCloud.

    I will try to get a hold on the 3rd party mail provider tomorrow, but if there are some bright minds out there that can see the issue, please chip in .

    If I have left something out, I will get it.