No announcement yet.

Contact import using idle/cron feature creating duplicates of each contact

  • Filter
  • Time
  • Show
Clear All
new posts

  • Contact import using idle/cron feature creating duplicates of each contact

    I'm importing 25000 email addresses (only) for a client mailing. I've had a ton of problems with import in the past so I upgraded to the latest version to try the idle/cron feature. I'm able to import this large list, but it's taking forever and upon checking it a short time ago, I noticed that it's at the 40,000 mark. Considering my list has 25000 emails, I checked and found that each email address is being created 4 times. So the import has been running now for over 24 hours and it's creating 4 of each record.

    I saw one other post in the forum with a user who had the same issue, and he solved it by only using one CPU. Problem is, I'm using a Digital Ocean server that I have some control over, but I have no earthly idea how to limit it to using 1 CPU. I love EspoCRM but the import issues are becoming a deal-breaker for me. I imported the same list into SuiteCRM in 30 minutes on the same server. I imported the same list into a local version of Sendblaster (email newsletter sending program) in a matter of minutes on a 10 year old HP dual-cpu computer.

    I don't understand why importing a simple list of emails is so problematic? There is no other information in this list. Just the email addresses. I've had trouble importing lists into Espo as small as a 1000 contacts. I had to break those up into groups of about 200 to get them to import without failing. I've also tried putting Espo on AWS servers, MediaTemple servers, Google Servers, Digital Ocean servers etc.All with the same import problems, so this doesn't appear to be a server problem.

    Anyway, how can I get this list in without these issues? Or is it just not possible?

    Chris Blair

  • #2
    Hello Chris,

    Could you explain it clearly?

    What entity do you import?
    Which columns does your file include?
    Did you use a duplicate checking?

    Clear all imported data and try again and check it, if you couldn't share data with us

    Best Regards,


    • #3
      Thought I was pretty clear. The CSV file had one column with email addresses. That's it. I was importing contacts. I DID use duplicate checking on the first try. I'm happy to report that I cleared out the list (had to do it through the database though as it takes forever through the application), then I re-imported using the idle/cron feature and turned off duplicate checking and the list imported within a couple minutes with no problem. So it appears the duplicate checking is the problem here. Thanks for the suggestion!

      Chris Blair


      • #4
        Thank you, Chris