No announcement yet.

Run Espo Scheduled Jobs

  • Filter
  • Time
  • Show
Clear All
new posts

  • Run Espo Scheduled Jobs

    I'm having a terrible time with this, and think it is probably easy and in front of my face. I created a scheduled task (using Synology DSM 6.0). I received an emailed task result status from my server - output is below:

    Task Scheduler has completed a scheduled task.
    Task: ESPO Crontab
    Start time: Tue, 25 Apr 2017 13:29:02 GMT Stop time: Tue, 25 Apr 2017 13:29:02 GMT Current status: 127 Standard output/error:

    Inside of ESPO, I changed the frequency of Schedule Report Sending to */1 * * * * so I can test by the minute until I get this figured out.

    I have a report set up to send daily - and I've been fudging the time to test it. The report is sent a user account and I have a valid email attached to it (I can send a test email to this account from Espo).

    End result is I get no email communication on the scheduled report.

    For reference, I am able to send a test email with the account owning the report.

    Any idea what I might be missing?

  • #2
    Is this a workflow? Check Scheduled Jobs, is it active?


    • #3
      It is the stock job included with the Advanced Pack. I still have it shown as Active


      • #4
        This job just schedules report sending - creates internal job at defined time (if it is not created yet). ( you could find in in database, table `job`, filter by`method` = 'sendReport')
        Check also data/logs, possible there is some error.


        • #5
          I found that there is some error in the code/ directory that I copied/pasted. After removing the > /dev/null 2>&1 I was left with this:

          * * * * * cd /volume1/web/bibensales; /usr/bin/php -f cron.php

          I ran the job from my server and got the below output:

          Task: ESPO Crontab
          Start time: Wed, 26 Apr 2017 12:33:02 GMT Stop time: Wed, 26 Apr 2017 12:33:02 GMT Current status: 255 Standard output/error:

          Am I missing something in the syntax? I confirmed the cron.php file can be edited. Not sure why it is not running
          Last edited by solomon023; 04-26-2017, 04:36 PM.


          • #6
            Also - I have the below error message in the log.

            {"exception":"[object] (PDOException(code: 0): could not find driver at /volume1/web/bibensales/application/Espo/ORM/EntityManager.php:138)"} []
            [2017-04-26 13:04:02] Espo.ERROR: Uncaught Exception PDOException: "could not find driver" at /volume1/web/bibensales/application/Espo/ORM/EntityManager.php line 138


            • #7
              Is there a good place to get tech support for this issue?


              • #8
                Did you install pdo_mysql extension?

                I have a problem using Laravel 5. When I run "php aritsan migrate", I got this error ************************************** * Application In Production! * *********************************...


                • #9
                  Anyway I can manually run a particular scheduled job for testing purpose


                  • #10
                    I have installed EspoCRM Community 5.5.6 on Synology DSM 6. The Cron setup does not work with the following line.
                    * * * * * cd / volume1 / web / system; / usr / local / bin / php -f cron.php> / dev / null 2> & 1.
                    What might be the problem? I'd like to use email notifications but Cron doesn't work. Sorry for the bad English, I speak a little bit about the language.


                    • #11
                      What operating system do you use?


                      • #12
                        Originally posted by Maximus View Post
                        What operating system do you use?
                        it seemt to be : Synology DSM 6

                        Synology have a cron scheduler in admin section.. try to create there. and correct the path to cron,php



                        • #13
                          The reason can be Cron should be configured for the web server owner. If your espo instance is on the server which owner is www-data, cron will not working for EspoCRM while it configured by root.


                          • #14
                            Unfortunately I don't know what Linux Distro is running on Synology.
                            The webserver and cron settings are shown in the attached images.
                            However, the cron does not run. Can somebody help me what's wrong?
                            Attached Files


                            • #15
                              Define who is your web server user and set the cron config to this user. Does 'http' the user of the web server?