Announcement

Collapse
No announcement yet.

Limitation of size of attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Limitation of size of attachments

    Hello, today I am getting a lot of reports from my colleagues that they are not able to create new documents for attachment with a size of more than 5MB or something around that.

    Till now we did not have such a problem. We updated our EspoCRM to version 7.2.0 a few days ago and since then it is happening so I would assume that it is somehow connected with changes in this feature https://www.espocrm.com/features/att...ocument-files/ or something like that. It is saying that it is the invalid file type, but if I reduce the size to under 5MB it's working even with the same file type. Click image for larger version

Name:	attachments.jpg
Views:	171
Size:	32.1 KB
ID:	82885

    Could you please confirm if you have made any changes in creating documents that could be causing this?

    Thanks a lot.

    Current version: 7.2.0
    Google Integration 1.5.4
    Advanced Pack 2.11.4

  • #2
    I found this information in docs, so I guess there were some changes in limitations. Could you please check if its working properly? I also found in our system requirements that we shoud be OK with our settings.
    I checked our settings and found that we have 256Mb Upload Max Size and 4Mb Upload Chu Click image for larger version

Name:	attach-settings.jpg
Views:	142
Size:	24.2 KB
ID:	82895 nk Size. I am not sure what exactly Chunk Size means so could you tell me if this is what is causing the issue?
    Click image for larger version  Name:	system_req.jpg Views:	0 Size:	36.6 KB ID:	82889



    Thanks a lot Click image for larger versionName:	attachments-docs.jpgViews:	0Size:	35.8 KBID:	82888
    Last edited by Jakub Grufik; 09-13-2022, 10:46 AM.

    Comment


    • #3
      Oh, I changed the Upload Chunk Size to 20MB and now it seems like it is working.
      In release notes I found this information https://github.com/espocrm/espocrm/issues/2329 but I did not get that now we are able to set those values on our own and it has been automatically reduced to 4Mb

      Comment


      • fioreid
        fioreid commented
        Editing a comment
        How and Where do you Edit the Chunk Size ? Please I really need help on this. Thank you.

      • Jakub Grufik
        Jakub Grufik commented
        Editing a comment
        hello, go to Administration -> Settings -> Scroll down and there it is

    • #4
      Could be that not allowed file type is uploaded. Allowed file types can be specified at Administration > Entity Manager > Document > Fields > File.

      Comment


      • #5
        Could be, but in my case, it was caused by 4Mb uploadChunkSize in settings. When I changed it to 20Mb it started to work again

        Comment


        • #6
          Fix: https://github.com/espocrm/espocrm/c...6206b419f8c6c0

          Comment


          • #7
            Merci Yuri
            using your advice, solved my upload problem too.

            "Could be that not allowed file type is uploaded. Allowed file types can be specified at Administration > Entity Manager > Document > Fields > File."

            Salutations amicales,
            Christophe​

            Comment

            Working...
            X