Announcement

Collapse
No announcement yet.

Error 403 with reports after update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 403 with reports after update

    Hello,
    I have a problem with the reports. I just updated EspoCRM and packs, and since then some reports have stopped working even though they were working before the update.
    I get a 403 error and the logs are as follows:


    Code:
    [2019-04-11 17:13:47] Espo.ERROR: API [GET]:/:controller/action/:action, Params:Array (     [controller] => Report     [action] => run ) , InputData:  - SelectManager::checkWhere: Complex expressions are forbidden. [] []
    [2019-04-11 17:13:47] Espo.ERROR: Display Error: SelectManager::checkWhere: Complex expressions are forbidden., Code: 403 URL: /api/v1/Report/action/run?id=5b4dd8c069ff82dc5&where%5B0%5D%5Btype%5D=in&where%5B0%5D%5Battribute%5D=stage&where%5B0%5D%5Bvalue%5D%5B%5D=Candidat&where%5B0%5D%5Bvalue%5D%5B%5D=Admis&where%5B0%5D%5Bvalue%5D%5B%5D=Inscrit&where%5B0%5D%5Bvalue%5D%5B%5D=Non+admis&where%5B0%5D%5Bvalue%5D%5B%5D=Sans+suite&where%5B0%5D%5Bvalue%5D%5B%5D=Rupture&where%5B1%5D%5Btype%5D=equals&where%5B1%5D%5Battribute%5D=anneeScolaireId&where%5B1%5D%5Bvalue%5D=59ee15ba2c418b667&where%5B2%5D%5Btype%5D=in&where%5B2%5D%5Battribute%5D=programme.niveau&where%5B2%5D%5Bvalue%5D%5B%5D=B1&where%5B2%5D%5Bvalue%5D%5B%5D=B2&where%5B2%5D%5Bvalue%5D%5B%5D=B3&where%5B2%5D%5Bvalue%5D%5B%5D=M1 [] []
    [2019-04-11 17:14:14] Espo.ERROR: API [GET]:/:controller/action/:action, Params:Array (     [controller] => Report     [action] => run ) , InputData:  - SelectManager::checkWhere: Complex expressions are forbidden. [] []
    [2019-04-11 17:14:14] Espo.ERROR: Display Error: SelectManager::checkWhere: Complex expressions are forbidden., Code: 403 URL: /api/v1/Report/action/run?id=5a61c126f123bac1d&where%5B0%5D%5Btype%5D=equals&where%5B0%5D%5Battribute%5D=concours.anneeScolaireId&where%5B0%5D%5Bvalue%5D=59ee15ba2c418b667&where%5B1%5D%5Battribute%5D=niveau [] []
    [2019-04-11 17:14:31] Espo.ERROR: API [GET]:/:controller/action/:action, Params:Array (     [controller] => Report     [action] => run ) , InputData:  - SelectManager::checkWhere: Complex expressions are forbidden. [] []
    [2019-04-11 17:14:31] Espo.ERROR: Display Error: SelectManager::checkWhere: Complex expressions are forbidden., Code: 403 URL: /api/v1/Report/action/run?id=5c49e81f46ae199f9&where%5B0%5D%5Btype%5D=equals&where%5B0%5D%5Battribute%5D=concours.anneeScolaireId&where%5B0%5D%5Bvalue%5D=59ec712a927b37c59&where%5B1%5D%5Btype%5D=before&where%5B1%5D%5Battribute%5D=concours.dateEnd&where%5B1%5D%5Bvalue%5D=2018-03-10&where%5B1%5D%5BdateTime%5D=true&where%5B1%5D%5BtimeZone%5D=Europe%2FParis [] []


    Can you help me to solve this problem please?

    Thank you for your help.

  • #2
    Hello,
    we will check it.

    Comment


    • #3
      Hello,
      Did you observe this bug on your side?
      I am annoyed that I can no longer consult my reports.
      Thank you for your help.

      Comment


      • #4
        Hi,

        Have you tried the latest version of Advanced Pack?

        It would have been helpful if you had provided more details about not working reports. It's extremely difficult to reproduce by trying multiple arbitrary combinations of report parameters.

        Comment


        • #5
          Hello,

          Yes, I use the latest version of the Advanced Pack.
          Reports that do not work are grid reports. The problem is related to the filter.

          Example :
          I associate my leads with events (events are an entity created by me). These events have a date field.
          The problem occurs when I want to filter my leads according to the date of an event. If I want to display all my leads, it works, if I want to display the leads I met during events between such and such date, it doesn't work.

          I would like to point out that I did not change anything in my report and that it worked very well before.

          Does this information help you to solve the problem?

          Thank you.

          Comment


          • #6
            Hi,

            Advanced Pack 2.2.1? I can't reproduce it on the latest version. There was an issue in 2.2.0.

            Comment


            • #7
              Hello,
              Espocrm was in 2.2.0... I just updated to 2.2.1, everything is ok!
              Thank you.

              Comment

              Working...
              X