Announcement

Collapse
No announcement yet.

Bad server response after Update to 8.2.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad server response after Update to 8.2.1

    Hello everyone,

    After updating to the latest version, EspoCRM no longer loads correctly. If anyone has had a similar problem or a solution, I would be very grateful.

    I am using PHP 8.2

    I have already tried the following:
    1. deactivated cache
    2. deleted cache
    3. rebuild executed

    The log file from Espo shows the following:​


    PHP-FPM Logs
    Code:
    PHP Fatal error: Declaration of Espo\Modules\Advanced\Services\Report::filterInput($data) must be compatible with Espo\Core\Record\Service::filterInput(stdClass $data): void in /home/uuuuuuu/htdocs/application/Espo/Modules/Advanced/Services/Report.php on line 5140

    No data records are displayed
    Click image for larger version

Name:	image.png
Views:	84
Size:	57.1 KB
ID:	104312


    Thanks

  • #2
    Hi,

    Do you have access to newer versions of Advanced Pack ? If yes, installing version >=3.1 will fix the problem.
    Last edited by yuri; 04-03-2024, 05:51 AM.

    Comment


    • #3
      My license has expired, I only use the version
      • Advanced Pack 2.15.5
      • Sales Pack 1.2.1

      I didn't know that the latest version was required. How could the installation just go through without it, shouldn't it be prevented ?

      Comment


      • #4
        It took us hundred of hours to test v8.2. Didn't catch all incompatibilities yet. We could test more, but increase all prices to make the development efforts justifiable.

        Comment


        • #5
          You can delete the filterInput function manually from application/Espo/Modules/Advanced/Services/Report.php.

          Comment


          • yuri
            yuri commented
            Editing a comment
            BTW, We had Advanced Pack v3.0 check in EspoCRM v8.0 upgrade. v2.15 was not supposed to be compatible.

        • #6
          Thanks for the quick reply.

          I have upgraded to the latest version of
          • Sales Pack 2.2.0
          • Advanced Pack 3.2.2
          and now it works again.


          Thank you very much!​

          Comment

          Working...
          X