Announcement

Collapse
No announcement yet.

ERROR 429, nothing in error logs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERROR 429, nothing in error logs

    Hello guys,
    I am sorry to bother you today with a lot of problems, but I need to resolve this one as it is making our system much slower than we are used to.

    Sometimes when I refresh our CRM system I am getting error 429, but nothing is being stored in the error log. When I get this error, the system is not loaded and we need to refresh it one more time.

    The only thing I found is the dev tools console with a lot of 429 ERRORS. Do you by any chance know, what could be causing this problem? A few days ago I deleted a lot of files from the upload directory in our repository. I think this could be connected with it. Is there any way how to fix this, please?

    Thanks a lot.
    Attached Files

  • #2
    Click image for larger version

Name:	image.png
Views:	106
Size:	155.8 KB
ID:	89362
    Full resolution screen, sorry for some reason original image is unreadable​

    Comment


    • #3
      You might have disabled cache in Espo, as a consequence you have many requests being made to webserver.

      This error is returned by your webserver. I googled the error number. "HTTP Error 429 is an HTTP response status code that indicates the client application has surpassed its rate limit, or number of requests they can send in a given period of time.​"

      Comment


      • Jakub Grufik
        Jakub Grufik commented
        Editing a comment
        wow man, you are right, for some reason USE Cache is disabled in the settings, even tho I have not disabled it. Maybe some other admin did without letting me know. I will try to enable it to see if the error will be solved. Thanks a lot man! Appreciate such a quick help!

    • #4
      yuri no errors after enabling cache, also the system is much much faster than without cache! thanks a lot for the help man! you are god

      Comment


      • #5
        Not sure if possible but if you have Workflow, perhaps making it Notify you when it is disable for too long or re-enable it automatically. Or perhaps feature request it to be

        Cache is one thing that unless for testing I see no reason to have it disable for long period.

        Comment

        Working...
        X