Announcement

Collapse
No announcement yet.

Trying to populate ArrayValue table for filtering to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to populate ArrayValue table for filtering to work

    Hello,
    I have installed EspoCRM for evaluation, and I want to synchronise accounts and opportunities with my present Oracle based CRM. All modifications in Oracle need to be transferred to EspoCRM.
    I managed to synchronize databases and I can report Oracle changes on MySQL database. The only problem that I have is on filtering accounts, based on the values of a multi-enum field.
    I noticed that all values were written in the array_values table at save process.
    I found on the forum that I could run the jobPopulateArrayValues job in order to populate the table. I ran the following command on my database :

    INSERT INTO `job` (id, name, service_name, method_name, execute_time) VALUES (UUID_SHORT(), 'jobPopulateArrayValues', 'App', 'jobPopulateArrayValues', NOW());

    On the Administration/Jobs dashboard, I see that I have a "Success" status value. No errors in the log file. I turned log mode to DEBUG, but nothing is logged on this job run.
    My array_value table is still empty and filtering does not work, whereas multi-enum values are seen on detailed views.

    - Do you know why jobPopulateArrayValues job does not work?
    - Is there another way to reach my goal, ie enable filter on imported fields

    Thanks for your answers.
    And congratulations for EspoCRM, I love this software!
    David


  • #2
    JFYI, jobPopulateArrayValues will be removed in the next version, but a console command introduced.

    php command.php populate-array-values

    https://github.com/espocrm/espocrm/b...rrayValues.php

    Comment


    • #3
      Thanks for your answer.
      I'm running a docker installation. How can I run a php command?
      Best regards
      David

      Comment

      Working...
      X