No announcement yet.

Cannot Convert Lead to Account

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Convert Lead to Account

    When hitting the "Convert" button for a Lead, I get an error 500 and the following message can be found in the error log:

    [2020-12-21 08:45:19] Espo.ERROR: Slim Application Error Type: TypeError Code: 0 Message: Argument 1 passed to Espo\ORM\BaseEntity::has() must be of the type string, null given, called in /home/si
    te/wwwroot/application/Espo/Modules/Crm/Services/Lead.php on line 194 File: /home/site/wwwroot/application/Espo/ORM/BaseEntity.php Line: 190 Trace: #0 /home/site/wwwroot/application/Espo/Modules/C
    rm/Services/Lead.php(194): Espo\ORM\BaseEntity->has(NULL) #1 /home/site/wwwroot/application/Espo/Modules/Crm/Controllers/Lead.php(63): Espo\Modules\Crm\Services\Lead->getConvertAttributes('5fe05ec
    d7104adf...') #2 /home/site/wwwroot/application/Espo/Core/ControllerManager.php(109): Espo\Modules\Crm\Controllers\Lead->postActionGetConvertAttributes(Array, Object(stdClass), Object(Espo\Core\Ap
    i\RequestWrapper), Object(Espo\Core\Api\ResponseWrapper)) #3 /home/site/wwwroot/application/Espo/Core/Api/RouteProcessor.php(84): Espo\Core\ControllerManager->process('Lead', 'getConvertAttri...',
    Object(Espo\Core\Api\RequestWrapper), Object(Espo\Core\Api\ResponseWrapper)) #4 /home/site/wwwroot/application/Espo/Core/ApplicationRunners/Api.php(184): Espo\Core\Api\RouteProcessor->process('/{
    controller}/a...', Object(Espo\Core\Api\RequestWrapper), Object(Espo\Core\Api\ResponseWrapper)) #5 /home/site/wwwroot/application/Espo/Core/ApplicationRunners/Api.php(112): Espo\Core\ApplicationRu
    nners\Api->processRequest(Array, Object(Espo\Core\Api\RequestWrapper), Object(Espo\Core\Api\ResponseWrapper), Array) #6 /home/site/wwwroot/vendor/slim/slim/Slim/Handlers/Strategies/RequestResponse
    .php(43): Espo\Core\ApplicationRunners\Api->Espo\Core\ApplicationRunners\{closure}(Object(S li m\Psr7\Request), Object(Slim\Psr7\Response), Array) #7 /home/site/wwwroot/vendor/slim/slim/Slim/Routing
    /Route.php(381): Slim\Handlers\Strategies\RequestResponse->__invoke(Object(Closure), Object(Slim\Psr7\Request), Object(Slim\Psr7\Response), Array) #8 /home/site/wwwroot/vendor/slim/slim/Slim/Middl
    ewareDispatcher.php(81): Slim\Routing\Route->handle(Object(Slim\Psr7\Request)) #9 /home/site/wwwroot/vendor/slim/slim/Slim/MiddlewareDispatcher.php(81): Slim\MiddlewareDispatcher->handle(Object(Sl
    im\Psr7\Request)) #10 /home/site/wwwroot/vendor/slim/slim/Slim/Routing/Route.php(341): Slim\MiddlewareDispatcher->handle(Object(Slim\Psr7\Request)) #11 /home/site/wwwroot/vendor/slim/slim/Slim/Rou
    ting/RouteRunner.php(84): Slim\Routing\Route->run(Object(Slim\Psr7\Request)) #12 /home/site/wwwroot/vendor/slim/slim/Slim/Middleware/RoutingMiddleware.php(60): Slim\Routing\RouteRunner->handle(Obj
    ect(Slim\Psr7\Request)) #13 /home/site/wwwroot/vendor/slim/slim/Slim/MiddlewareDispatcher.php(140): Slim\Middleware\RoutingMiddleware->process(Object(Slim\Psr7\Request), Object(Slim\Routing\RouteR
    unner)) #14 /home/site/wwwroot/vendor/slim/slim/Slim/Middleware/ErrorMiddleware.php(107): class@anonymous->handle(Object(Slim\Psr7\Request)) #15 /home/site/wwwroot/vendor/slim/slim/Slim/Middleware
    Dispatcher.php(140): Slim\Middleware\ErrorMiddleware->process(Object(Slim\Psr7\Request), Object(class@anonymous)) #16 /home/site/wwwroot/vendor/slim/slim/Slim/MiddlewareDispatcher.php(81): class@a
    nonymous->handle(Object(Slim\Psr7\Request)) #17 /home/site/wwwroot/vendor/slim/slim/Slim/App.php(215): Slim\MiddlewareDispatcher->handle(Object(Slim\Psr7\Request)) #18 /home/site/wwwroot/vendor/sl
    im/slim/Slim/App.php(199): Slim\App->handle(Object(Slim\Psr7\Request)) #19 /home/site/wwwroot/application/Espo/Core/ApplicationRunners/Api.php(94): Slim\App->run() #20 /home/site/wwwroot/applicati
    on/Espo/Core/Application.php(107): Espo\Core\ApplicationRunners\Api->run(NULL) #21 /home/site/wwwroot/api/v1/index.php(37): Espo\Core\Application->run('Espo\\Core\\Appli...') #22 {main} Tips: To d
    isplay error details in HTTP response set "displayErrorDetails" to true in the ErrorHandler constructor. [] []
    Espo Version is 6.0.8 and System Requirements are all green.

    Any ideas?

  • #2
    We did a lot of tests of the Lead Conversion module and haven't encountered this issue.
    Please check whether you don't have any malformed fields in the /EntityDefs/Account.json file neither in the /application nor /custom directory.


    • #3
      Hi Maximus, I've found the EntityDefs/Account.json in /custom/Espo/Custom/Resources/metadata/entityDefs/Account.json and it is a valid json. However, I wasn't able to locate EntityDefs/Account.json in /application/Espo/Resources/metadata/entityDefs/ - can you maybe point me to the right folder?


      • #4
        Maximus sorry to bother you again, but can you maybe share other ideas about this issue?


        • #5
          line 89 -> $lead = $this->getEntity($id);
          line 194 -> $lead->has(...).

          so id is wrong ? put a Log for see what's is ID $GLOBALS['log']->warning(...);

          it's /application/Espo/Modules/Crm/...


          • #6
            item Hi and thanks for the reply. Before trying as you suggested, I wanted to update to the latest Espo version. I'm not on 6.0.9 and the error message upon Lead Conversion changed to the following:

            "Error 500: Not compatible fields in 'convertFields' map."

            Any idea, what could hence be the reason?


            • #7
              i think.. you need to give more info :
              php version
              espoCrm version

              database version
              apache version

              And always give log of error (not message on client side)


              • #8
                Error Message:
                [2021-01-12 05:46:37] Espo.ERROR: (500) Not compatible fields in 'convertFields' map.; POST /Lead/action/getConvertAttributes; line: 198, file: /home/site/wwwroot/application/Espo/Modules/Crm/Services/Lead.php [] []
                PHPversion: 7.2.5
                Espo version: 6.0.9
                MySQL version: 5.7.29-log

                It's an Azure Web App running on nginx.


                • #9
                  Hi Tobias,
                  I had excatly the same errormessages. The problem was that I added contacts two times as multiple selection. After removing one everything worked again.
                  Perhaps this is helpful for you...


                  • #10
                    Hi boris,
                    Could you provide the steps to reproduce?


                    • #11
                      I have the same problem after upgrading from 6.0.8 to 6.0.10, if there is a solution please let me know

                      [2021-02-09 10:54:35] Espo.ERROR: (500) Not compatible fields in 'convertFields' map.; POST /Lead/action/getConvertAttributes; line: 198, file: /home/today/today/www/CRM/application/Espo/Modules/Crm/Services/Lead.php [] []
                      Last edited by alexisc; 02-09-2021, 11:21 AM.


                      • #12
                        boris thanks for the hint. However, I have zero Contacts linked. I created a test lead with fake data, quite naked entity in fact. But the error still occurs.

                        BUT here's the solution: I removed the "Link Multiple" field from the Lead entity ( and presto, conversions worked again.

                        yuri please investigate since this filed is there by default.


                        • #13
                          Originally posted by tobias View Post
                          the solution: I removed the "Link Multiple" field from the Lead entity
                          I confirm this solution works


                          • #14

                            tobias , can you please show me which "Link Multiple" field you removed? I am having same problem. My version is 6.0.10.


                            • #15
                              The one associated with Contacts entity, since this was the link causing trouble.