Announcement

Collapse
No announcement yet.

Force User To Send From Specific Email Account

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Force User To Send From Specific Email Account

    Is there a way to force a user to send from a group email account and restrict them from sending from their own account? I'm trying to provision my instance so that when a user goes to send an email they can only send from a group account that is monitored by the CRM for email import. This way no emails are sent directly to anyone's personal company email and are only sent directly to the CRM.

    In this example I'd be disabling marc@edgrradio.com and forcing the use of sales@encoremediasystems.com (see attached image)
    Click image for larger version

Name:	screenshot-crm.studiolinkhub.com-2019.11.25-14_25_17.png
Views:	692
Size:	79.1 KB
ID:	53705
    Attached Files

  • #2
    Hello,
    please try this:
    1. deactivate a user Personal Email Account;
    2. disable access to Personal Email Account in the role.

    Comment


    • #3
      Originally posted by Maximus View Post
      Hello,
      please try this:
      1. deactivate a user Personal Email Account;
      2. disable access to Personal Email Account in the role.
      How do I disable a user's Personal Email Account. I removed it from their profile as a test but without that field they won't get email notifications. Suggestions?

      Comment


      • #4
        > I removed it from their profile.
        Did you delete the email address from the user profile? If yes, then set it back please. To disable a user's Personal Email Account you need to go Emails -> Personal Email Account -> your-user-personal-email-account -> status -> Inactive.

        Comment


        • #5
          This user does not have any Personal Email Accounts associated with them. Should I add one to they account and set it inactive?

          Comment


          • #6
            No, you don't need to do it. I assume that you have some SMTP configs in the user's preferences. Please go to Users -> open a user's profile -> in the top-right corner click the 'three-dot' button -> Preferences -> check for the SMTP configs in the bottom of Preferences.

            Comment


            • #7
              It's not there. I know it's not a permission thing since I'm a Super-Admin.

              Comment


              • #8
                According to the system logic if the user has an email address in his profile, this address will be always autofilled in the FROM field. But, if you haven't the Personal Email Account with the SMTP configs that linked to this address or General Outbound emails SMTP configs that linked to this address, the user will not be able to send an email from it.
                If you want to avoid autofill logic, you need to make a code customization. Investigate this file /client/src/views/email/fields/compose-from-address.js.

                Comment


                • #9
                  I'll take a look as soon as I get the chance and report back

                  Comment


                  • #10
                    Hi Maximus,

                    I'm not very familiar with JavaScript. Could you please provide some examples of the modifications that I'll need to make?

                    Comment


                    • #11
                      > I'm not very familiar with JavaScript.
                      So am I. So the best way is to create a topic in the developer help branch here https://forum.espocrm.com/forum/developer-help.

                      Comment


                      • #12
                        Thanks! I'll start that topic in a bit and link to it here.

                        Comment


                        • #13
                          Latecomer to the talk, but let me share my experience with this issue - although maybe it's not exactly the same need I had.

                          I wanted to force users to send emails from their group accounts but i also wanted them to be able to recover their passwords without my intervention (i'm the sys admin for the company). So each user would (in theory) need to have a personal account (really personal, not the company's individual email account) to be able to recover their passwords when needed.

                          So one day i finally tried to test-recover my password and I finally saw that the user needs to provide a valid email address. By valid I mean an email address listed on the user's settings. Each user can have as many emails as needed, but just one will be the default email address - the one which, by default, appears when they start to compose an email.

                          So, i my case, this solves the issue: I need the default email address to be the group email used by each user. This is the main address that i set for the user. The secondary address will, probably, be the user's personal email, for password recovery. This way, at least for my needs, less mistakes are going to be made - like sending emails from individual business accounts, which is something we are trying to end as much as possible.

                          My 2 cents.

                          Comment


                          • #14
                            Extra 2 cents:

                            Using this information

                            Originally posted by Maximus View Post
                            If you want to avoid autofill logic, you need to make a code customization. Investigate this file /client/src/views/email/fields/compose-from-address.js.
                            I've added the following to the code:
                            Code:
                             this.list.unshift('');
                            Just bellow this
                            Code:
                             this.list = _.uniq(this.list);
                            This way, the first from-email address is empty. Now, I can customize email form logic so the user has to select an email address to send from. I'll keep posting my findings.

                            Comment

                            Working...
                            X