Announcement

Collapse
No announcement yet.

Entity relationship fields are not working in search filters.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Entity relationship fields are not working in search filters.

    In User entity i added Many to Many relation with Role Entity , And in the user grid listing page i shown Role names per user row , but in search filter Role is not working , how to solve this issue ? as i need to filter user by roles.

    Click image for larger version

Name:	user-grid.PNG
Views:	516
Size:	47.5 KB
ID:	48122

  • #2
    Hello,
    what EspoCRM version do you use?

    Comment


    • #3
      Hi Maximus

      I'm using EspoCRM-5.5.6 version .

      Comment


      • #4
        Have you made some custom changes in the code before you faced this issue?
        Please, press F12 and reload the page. Check for the errors in the network tab and console tab.

        Comment


        • #5
          No all my custom changes are inside custom folder only and also i tried to create 2 entities and map fields with them and still search filter is not working

          Comment


          • #6
            I installed a fresh espo 5.6.1 and created user with role and tried to filter user by role name , its not working , no customization is done . Please let me know how to solve this . Thanks in advance.

            Comment


            • #7
              Could you please archive (.zip) and attached the Custom directory from /EspoCRM/custom/Espo/. I will test it on my instance.

              Comment


              • #8
                Sure please find the attachment
                Attached Files

                Comment

                Working...
                X